AdiIRCAPI Namespace

Documentation for the AdiIRC plugin API.
Classes
 | Class | Description
Public class | RawDataArgs | RawDataArgs
Interfaces
 | Interface | Description
Public interface | IChannel | Represents a channel object
Public interface | IChannelMask | Interface for ban/except/invite/quiet lists
Public interface | ICustomWindow | Represents a custom window
Public interface | IEditbox | Represents a Editbox
Public interface | IEditboxOptions | Interface for returning Editbox options
Public interface | IMessagesOptions | Interface for returning Messages options
Public interface | IPlugin | Inherit from this class in your plugin, e.g class MyPlugin : IPlugin
Public interface | IPluginHost | Overall plugin manager
Public interface | IServer | Represents a server object
Public interface | ITextView | Represents a TextView
Public interface | ITools | Various tools
Public interface | IUser | Represents a user
Public interface | IWindow | Represents a form window
Delegates
 | Delegate | Description
Public delegate | ChannelNotice | Delegate gets called when a IChannel recives a notice
Public delegate | Command | Delegate gets called when your user types a command Window can be IServer (server window), IChannel (channel window), IUser (private window)
Public delegate | Connect | Delegate gets called when a IServer connects
Public delegate | Disconnect | Delegate gets called when a IServer disconnects
Public delegate | EditboxKeyDown | Delegate gets called when a key is pressed down in a Editbox
Public delegate | GetData | Delegate gets called when a IServer retrives raw data
Public delegate | Identifier | Delegate gets called when the command is called as a $identifier in a script Window can be IServer (server window), IChannel (channel window), IUser (private window)
Public delegate | Invite | Delegate gets called when a user on IChannel revices an invite
Public delegate | Join | Delegate gets called when a IUser joines a IChannel
Public delegate | Kick | Delegate gets called when a IUser is kicked from IChannel
Public delegate | Menu | Delegate gets called when a menu is opened
Public delegate | Message | Delegate gets called when a IChannel revices a message
Public delegate | Mode | Delegate gets called when a IChannel revices a mode
Public delegate | Nick | Delegate gets called when a IUser change nick
Public delegate | OptionsChanged | Delegate gets called when the user changes a options and the config file is reloaded.
Public delegate | Part | Delegate gets called when a IUser parts a IChannel
Public delegate | PrivateMessage | Delegate gets called when your IUser recives a private message
Public delegate | Quit | Delegate gets called when a IUser quits the IServer
Public delegate | RawData | Delegate gets called when any raw data is recieved to the IServer. You can modify the byte array args, AdiIRC will then parse this array with the proper encoding. If the array is set to null or zero bytes, the raw message is ignored by AdiIRC.
Public delegate | Registered | Delegate gets called when a IServer is registered
Public delegate | SendData | Delegate gets called when user sends data to the IServer
Public delegate | ServerNotice | Delegate gets called when a IServer recives a notice
Public delegate | Topic | Delegate gets called when a IUser changes topic in IChannel
Public delegate | UserInvite | Delegate gets called when your IUser recives an IChannel invite
Public delegate | UserJoin | Delegate gets called when your IUser joines a IChannel
Public delegate | UserKick | Delegate gets called when your IUser is kicked from IChannel
Public delegate | UserMessage | Delegate gets called when you send a message to IChannel
Public delegate | UserMode | Delegate gets called when your IUser revices a umode
Public delegate | UserNick | Delegate gets called when your IUser change nick
Public delegate | UserNotice | Delegate gets called when your IUser recives a notice
Public delegate | UserPart | Delegate gets called when your IUser parts a IChannel
Public delegate | UserQuit | Delegate gets called when your IUser quits the IServer
Enumerations
 | Enumeration | Description
Public enumeration | EatData | Return data to the delegates stating whether the program should ignore none, ignore text output, or ignore everything Use with caution
Public enumeration | MenuType | Used to determine the menu type during a OnMenu event
Public enumeration | WindowType | The window types for a IWindow


ChannelNotice Delegate

Delegate gets called when a IChannel recives a notice

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ChannelNotice(
    IServer Server,
    IChannel Channel,
    IUser User,
    string Notice,
    out EatData Return
)
Public Delegate Sub ChannelNotice (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    Notice As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void ChannelNotice(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    String^ Notice,
    [OutAttribute] EatData% Return
)
type ChannelNotice =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        Notice : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
Notice
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Command Delegate

Delegate gets called when your user types a command Window can be IServer (server window), IChannel (channel window), IUser (private window)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Command(
    Object Window,
    string Command,
    string Args
)
Public Delegate Sub Command (
    Window As Object,
    Command As String,
    Args As String
)
public delegate void Command(
    Object^ Window,
    String^ Command,
    String^ Args
)
type Command =
    delegate of
        Window : Object *
        Command : string *
        Args : string -> unit

Parameters

Window
Type: SystemObject
Object
Command
Type: SystemString
String
Args
Type: SystemString
String
See Also

Reference

AdiIRCAPI Namespace


Connect Delegate

Delegate gets called when a IServer connects

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Connect(
    IServer Server
)
Public Delegate Sub Connect (
    Server As IServer
)
public delegate void Connect(
    IServer^ Server
)
type Connect =
    delegate of
        Server : IServer -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
See Also

Reference

AdiIRCAPI Namespace


Disconnect Delegate

Delegate gets called when a IServer disconnects

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Disconnect(
    IServer Server
)
Public Delegate Sub Disconnect (
    Server As IServer
)
public delegate void Disconnect(
    IServer^ Server
)
type Disconnect =
    delegate of
        Server : IServer -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
See Also

Reference

AdiIRCAPI Namespace


EatData Enumeration

Return data to the delegates stating whether the program should ignore none, ignore text output, or ignore everything Use with caution

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EatData
Public Enumeration EatData
public enum class EatData
type EatData
Members
Member name | Value | Description
EatNone | 0 | Hide no part of the event.
EatText | 1 | Hide the text output from this event.
EatAll | 2 | Hide the entire event.
See Also

Reference

AdiIRCAPI Namespace


EditboxKeyDown Delegate

Delegate gets called when a key is pressed down in a Editbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void EditboxKeyDown(
    IServer Server,
    Object Window,
    IEditbox Editbox,
    KeyEventArgs KeyPressEventArgs
)
Public Delegate Sub EditboxKeyDown (
    Server As IServer,
    Window As Object,
    Editbox As IEditbox,
    KeyPressEventArgs As KeyEventArgs
)
public delegate void EditboxKeyDown(
    IServer^ Server,
    Object^ Window,
    IEditbox^ Editbox,
    KeyEventArgs^ KeyPressEventArgs
)
type EditboxKeyDown =
    delegate of
        Server : IServer *
        Window : Object *
        Editbox : IEditbox *
        KeyPressEventArgs : KeyEventArgs -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Window
Type: SystemObject
Editbox
Type: AdiIRCAPIIEditbox
KeyPressEventArgs
Type: System.Windows.FormsKeyEventArgs
See Also

Reference

AdiIRCAPI Namespace


GetData Delegate

Delegate gets called when a IServer retrives raw data

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void GetData(
    IServer Server,
    string Data,
    out EatData Return
)
Public Delegate Sub GetData (
    Server As IServer,
    Data As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void GetData(
    IServer^ Server,
    String^ Data,
    [OutAttribute] EatData% Return
)
type GetData =
    delegate of
        Server : IServer *
        Data : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Data
Type: SystemString
Return
Type: AdiIRCAPIEatData
See Also

Reference

AdiIRCAPI Namespace


IChannel Interface

Represents a channel object

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IChannel
Public Interface IChannel
public interface class IChannel
type IChannel =  interface end

The IChannel type exposes the following members.

Properties
 | Name | Description
Public property | BanList | Returns the IChannel ban list
Public property | ChannelLimit | Gets the IChannel channellimit
Public property | ChannelModeArgs | Returns the IChannel channel modes with arguments
Public property | ChannelModes | Gets the IChannel mode
Public property | ChannelPassword | Gets the IChannel password
Public property | Editbox | Returns the IEditbox for the IChannel window (can be null)
Public property | ExceptList | Returns the IChannel except list
Public property | GetUsers | Gets a collection of users in the IChannel
Public property | InviteList | Returns the IChannel invite list
Public property | IsInviteOnly | Gets whether the IChannel is invite only
Public property | IsModerated | Gets whether the IChannel is moderated
Public property | IsPrivate | Gets whether the IChannel is private
Public property | IsSecret | Gets whether the IChannel is secret
Public property | Name | Get the IChannel name
Public property | NoExternalMsgs | Gets whether the IChannel can recive external messages
Public property | OnlyOpsSetTopic | Gets whether only operators can set topic in IChannel
Public property | QuietList | Returns the IChannel quiet list
Public property | Server | Get the IServer associated with this IChannel
Public property | Topic | Get the IChannel topic
Public property | TopicSetAt | Get date of when the current topic was set
Public property | TopicSetBy | Get nick of whom set the current topic
Public property | Window | returns the IWindow associated with this IChannel
Top
See Also

Reference

AdiIRCAPI Namespace


IChannel Properties

The IChannel type exposes the following members.

Properties
 | Name | Description
Public property | BanList | Returns the IChannel ban list
Public property | ChannelLimit | Gets the IChannel channellimit
Public property | ChannelModeArgs | Returns the IChannel channel modes with arguments
Public property | ChannelModes | Gets the IChannel mode
Public property | ChannelPassword | Gets the IChannel password
Public property | Editbox | Returns the IEditbox for the IChannel window (can be null)
Public property | ExceptList | Returns the IChannel except list
Public property | GetUsers | Gets a collection of users in the IChannel
Public property | InviteList | Returns the IChannel invite list
Public property | IsInviteOnly | Gets whether the IChannel is invite only
Public property | IsModerated | Gets whether the IChannel is moderated
Public property | IsPrivate | Gets whether the IChannel is private
Public property | IsSecret | Gets whether the IChannel is secret
Public property | Name | Get the IChannel name
Public property | NoExternalMsgs | Gets whether the IChannel can recive external messages
Public property | OnlyOpsSetTopic | Gets whether only operators can set topic in IChannel
Public property | QuietList | Returns the IChannel quiet list
Public property | Server | Get the IServer associated with this IChannel
Public property | Topic | Get the IChannel topic
Public property | TopicSetAt | Get date of when the current topic was set
Public property | TopicSetBy | Get nick of whom set the current topic
Public property | Window | returns the IWindow associated with this IChannel
Top
See Also

Reference

IChannel Interface


IChannel.BanList Property

A Sandcastle Documented Class Library

IChannelBanList Property

Returns the IChannel ban list

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
Collection<IChannelMask> BanList { get; }
ReadOnly Property BanList As Collection(Of IChannelMask)
    Get
property Collection<IChannelMask^>^ BanList {
    Collection<IChannelMask^>^ get ();
}
abstract BanList : Collection<IChannelMask> with get

Property Value

Type: Collection IChannelMask
See Also

Reference

IChannel Interface


IChannel.ChannelLimit Property

IChannelChannelLimit Property

Gets the IChannel channellimit

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int ChannelLimit { get; }
ReadOnly Property ChannelLimit As Integer
    Get
property int ChannelLimit {
    int get ();
}
abstract ChannelLimit : int with get

Property Value

Type: Int32
See Also

Reference

IChannel Interface


IChannel.ChannelModeArgs Property

IChannelChannelModeArgs Property

Returns the IChannel channel modes with arguments

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
SortedDictionary<string, string> ChannelModeArgs { get; }
ReadOnly Property ChannelModeArgs As SortedDictionary(Of String, String)
    Get
property SortedDictionary<String^, String^>^ ChannelModeArgs {
    SortedDictionary<String^, String^>^ get ();
}
abstract ChannelModeArgs : SortedDictionary<string, string> with get

Property Value

Type: SortedDictionary String, String
See Also

Reference

IChannel Interface


IChannel.ChannelModes Property

IChannelChannelModes Property

Gets the IChannel mode

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ChannelModes { get; }
ReadOnly Property ChannelModes As String
    Get
property String^ ChannelModes {
    String^ get ();
}
abstract ChannelModes : string with get

Property Value

Type: String
See Also

Reference

IChannel Interface


IChannel.ChannelPassword Property

IChannelChannelPassword Property

Gets the IChannel password

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ChannelPassword { get; }
ReadOnly Property ChannelPassword As String
    Get
property String^ ChannelPassword {
    String^ get ();
}
abstract ChannelPassword : string with get

Property Value

Type: String
See Also

Reference

IChannel Interface


IChannel.Editbox Property

IChannelEditbox Property

Returns the IEditbox for the IChannel window (can be null)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditbox Editbox { get; }
ReadOnly Property Editbox As IEditbox
    Get
property IEditbox^ Editbox {
    IEditbox^ get ();
}
abstract Editbox : IEditbox with get

Property Value

Type: IEditbox
See Also

Reference

IChannel Interface


IChannel.ExceptList Property

IChannelExceptList Property

Returns the IChannel except list

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
Collection<IChannelMask> ExceptList { get; }
ReadOnly Property ExceptList As Collection(Of IChannelMask)
    Get
property Collection<IChannelMask^>^ ExceptList {
    Collection<IChannelMask^>^ get ();
}
abstract ExceptList : Collection<IChannelMask> with get

Property Value

Type: Collection IChannelMask
See Also

Reference

IChannel Interface


IChannel.GetUsers Property

IChannelGetUsers Property

Gets a collection of users in the IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetUsers { get; }
ReadOnly Property GetUsers As ICollection
    Get
property ICollection^ GetUsers {
    ICollection^ get ();
}
abstract GetUsers : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IChannel Interface


IChannel.InviteList Property

IChannelInviteList Property

Returns the IChannel invite list

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
Collection<IChannelMask> InviteList { get; }
ReadOnly Property InviteList As Collection(Of IChannelMask)
    Get
property Collection<IChannelMask^>^ InviteList {
    Collection<IChannelMask^>^ get ();
}
abstract InviteList : Collection<IChannelMask> with get

Property Value

Type: Collection IChannelMask
See Also

Reference

IChannel Interface


IChannel.IsInviteOnly Property

IChannelIsInviteOnly Property

Gets whether the IChannel is invite only

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsInviteOnly { get; }
ReadOnly Property IsInviteOnly As Boolean
    Get
property bool IsInviteOnly {
    bool get ();
}
abstract IsInviteOnly : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface


IChannel.IsModerated Property

IChannelIsModerated Property

Gets whether the IChannel is moderated

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsModerated { get; }
ReadOnly Property IsModerated As Boolean
    Get
property bool IsModerated {
    bool get ();
}
abstract IsModerated : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface


IChannel.IsPrivate Property

IChannelIsPrivate Property

Gets whether the IChannel is private

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPrivate { get; }
ReadOnly Property IsPrivate As Boolean
    Get
property bool IsPrivate {
    bool get ();
}
abstract IsPrivate : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface


IChannel.IsSecret Property

IChannelIsSecret Property

Gets whether the IChannel is secret

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSecret { get; }
ReadOnly Property IsSecret As Boolean
    Get
property bool IsSecret {
    bool get ();
}
abstract IsSecret : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface


IChannel.Name Property

IChannelName Property

Get the IChannel name

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IChannel Interface


IChannel.NoExternalMsgs Property

IChannelNoExternalMsgs Property

Gets whether the IChannel can recive external messages

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NoExternalMsgs { get; }
ReadOnly Property NoExternalMsgs As Boolean
    Get
property bool NoExternalMsgs {
    bool get ();
}
abstract NoExternalMsgs : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface


IChannel.OnlyOpsSetTopic Property

IChannelOnlyOpsSetTopic Property

Gets whether only operators can set topic in IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnlyOpsSetTopic { get; }
ReadOnly Property OnlyOpsSetTopic As Boolean
    Get
property bool OnlyOpsSetTopic {
    bool get ();
}
abstract OnlyOpsSetTopic : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface


IChannel.QuietList Property

IChannelQuietList Property

Returns the IChannel quiet list

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
Collection<IChannelMask> QuietList { get; }
ReadOnly Property QuietList As Collection(Of IChannelMask)
    Get
property Collection<IChannelMask^>^ QuietList {
    Collection<IChannelMask^>^ get ();
}
abstract QuietList : Collection<IChannelMask> with get

Property Value

Type: Collection IChannelMask
See Also

Reference

IChannel Interface


IChannel.Server Property

IChannelServer Property

Get the IServer associated with this IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IServer Server { get; }
ReadOnly Property Server As IServer
    Get
property IServer^ Server {
    IServer^ get ();
}
abstract Server : IServer with get

Property Value

Type: IServer
See Also

Reference

IChannel Interface


IChannel.Topic Property

IChannelTopic Property

Get the IChannel topic

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Topic { get; }
ReadOnly Property Topic As String
    Get
property String^ Topic {
    String^ get ();
}
abstract Topic : string with get

Property Value

Type: String
See Also

Reference

IChannel Interface


IChannel.TopicSetAt Property

IChannelTopicSetAt Property

Get date of when the current topic was set

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string TopicSetAt { get; }
ReadOnly Property TopicSetAt As String
    Get
property String^ TopicSetAt {
    String^ get ();
}
abstract TopicSetAt : string with get

Property Value

Type: String
See Also

Reference

IChannel Interface


IChannel.TopicSetBy Property

IChannelTopicSetBy Property

Get nick of whom set the current topic

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string TopicSetBy { get; }
ReadOnly Property TopicSetBy As String
    Get
property String^ TopicSetBy {
    String^ get ();
}
abstract TopicSetBy : string with get

Property Value

Type: String
See Also

Reference

IChannel Interface


IChannel.Window Property

IChannelWindow Property

returns the IWindow associated with this IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IWindow Window { get; }
ReadOnly Property Window As IWindow
    Get
property IWindow^ Window {
    IWindow^ get ();
}
abstract Window : IWindow with get

Property Value

Type: IWindow
See Also

Reference

IChannel Interface


IChannelMask Interface

Interface for ban/except/invite/quiet lists

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IChannelMask
Public Interface IChannelMask
public interface class IChannelMask
type IChannelMask =  interface end

The IChannelMask type exposes the following members.

Properties
 | Name | Description
Public property | Mask |
Public property | SetAt |
Public property | SetBy |
Top
See Also

Reference

AdiIRCAPI Namespace


IChannelMask Properties

The IChannelMask type exposes the following members.

Properties
 | Name | Description
Public property | Mask |
Public property | SetAt |
Public property | SetBy |
Top
See Also

Reference

IChannelMask Interface


IChannelMask.Mask Property

IChannelMaskMask Property

[Missing <summary> documentation for "P:AdiIRCAPI.IChannelMask.Mask"]

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Mask { get; }
ReadOnly Property Mask As String
    Get
property String^ Mask {
    String^ get ();
}
abstract Mask : string with get

Property Value

Type: String
See Also

Reference

IChannelMask Interface


IChannelMask.SetAt Property

IChannelMaskSetAt Property

[Missing <summary> documentation for "P:AdiIRCAPI.IChannelMask.SetAt"]

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
long SetAt { get; }
ReadOnly Property SetAt As Long
    Get
property long long SetAt {
    long long get ();
}
abstract SetAt : int64 with get

Property Value

Type: Int64
See Also

Reference

IChannelMask Interface


IChannelMask.SetBy Property

IChannelMaskSetBy Property

[Missing <summary> documentation for "P:AdiIRCAPI.IChannelMask.SetBy"]

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string SetBy { get; }
ReadOnly Property SetBy As String
    Get
property String^ SetBy {
    String^ get ();
}
abstract SetBy : string with get

Property Value

Type: String
See Also

Reference

IChannelMask Interface


ICustomWindow Interface

Represents a custom window

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICustomWindow
Public Interface ICustomWindow
public interface class ICustomWindow
type ICustomWindow =  interface end

The ICustomWindow type exposes the following members.

Properties
 | Name | Description
Public property | Editbox | Returns the IEditbox for the ICustomwindow (can be null)
Public property | Name | Retrive the custom window name
Public property | PictureWindow | Returns True if the custom window is a picture window, otherwise false
Public property | Window | returns the IWindow associated with this ICustomWindow
Top
See Also

Reference

AdiIRCAPI Namespace


ICustomWindow Properties

The ICustomWindow type exposes the following members.

Properties
 | Name | Description
Public property | Editbox | Returns the IEditbox for the ICustomwindow (can be null)
Public property | Name | Retrive the custom window name
Public property | PictureWindow | Returns True if the custom window is a picture window, otherwise false
Public property | Window | returns the IWindow associated with this ICustomWindow
Top
See Also

Reference

ICustomWindow Interface


ICustomWindow.Editbox Property

ICustomWindowEditbox Property

Returns the IEditbox for the ICustomwindow (can be null)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditbox Editbox { get; }
ReadOnly Property Editbox As IEditbox
    Get
property IEditbox^ Editbox {
    IEditbox^ get ();
}
abstract Editbox : IEditbox with get

Property Value

Type: IEditbox
See Also

Reference

ICustomWindow Interface


ICustomWindow.Name Property

ICustomWindowName Property

Retrive the custom window name

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

ICustomWindow Interface


ICustomWindow.PictureWindow Property

ICustomWindowPictureWindow Property

Returns True if the custom window is a picture window, otherwise false

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PictureWindow { get; }
ReadOnly Property PictureWindow As Boolean
    Get
property bool PictureWindow {
    bool get ();
}
abstract PictureWindow : bool with get

Property Value

Type: Boolean
See Also

Reference

ICustomWindow Interface


ICustomWindow.Window Property

ICustomWindowWindow Property

returns the IWindow associated with this ICustomWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IWindow Window { get; }
ReadOnly Property Window As IWindow
    Get
property IWindow^ Window {
    IWindow^ get ();
}
abstract Window : IWindow with get

Property Value

Type: IWindow
See Also

Reference

ICustomWindow Interface


Identifier Delegate

Delegate gets called when the command is called as a $identifier in a script Window can be IServer (server window), IChannel (channel window), IUser (private window)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Identifier(
    Object Window,
    string Command,
    string[] Args,
    out string Return
)
Public Delegate Sub Identifier (
    Window As Object,
    Command As String,
    Args As String(),
    <OutAttribute> ByRef Return As String
)
public delegate void Identifier(
    Object^ Window,
    String^ Command,
    array<String^>^ Args,
    [OutAttribute] String^% Return
)
type Identifier =
    delegate of
        Window : Object *
        Command : string *
        Args : string[] *
        Return : string byref -> unit

Parameters

Window
Type: SystemObject
Object
Command
Type: SystemString
String
Args
Type: SystemString
String
Return
Type: SystemString
String
See Also

Reference

AdiIRCAPI Namespace


IEditbox Interface

Represents a Editbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditbox
Public Interface IEditbox
public interface class IEditbox
type IEditbox =  interface end

The IEditbox type exposes the following members.

Properties
 | Name | Description
Public property | SelectedText | Returns the selected text in the IEditbox
Public property | SelectionLength | Returns the selection length in the IEditbox
Public property | SelectionStart | Returns the selection start position in the IEditbox
Public property | Text | Returns the IEditbox text
Top
Methods
 | Name | Description
Public method | Select | Selects a substring of the Text
Top
See Also

Reference

AdiIRCAPI Namespace


IEditbox Properties

The IEditbox type exposes the following members.

Properties
 | Name | Description
Public property | SelectedText | Returns the selected text in the IEditbox
Public property | SelectionLength | Returns the selection length in the IEditbox
Public property | SelectionStart | Returns the selection start position in the IEditbox
Public property | Text | Returns the IEditbox text
Top
See Also

Reference

IEditbox Interface


IEditbox.SelectedText Property

IEditboxSelectedText Property

Returns the selected text in the IEditbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

Property Value

Type: String
See Also

Reference

IEditbox Interface


IEditbox.SelectionLength Property

IEditboxSelectionLength Property

Returns the selection length in the IEditbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditbox Interface


IEditbox.SelectionStart Property

IEditboxSelectionStart Property

Returns the selection start position in the IEditbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditbox Interface


IEditbox.Text Property

IEditboxText Property

Returns the IEditbox text

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IEditbox Interface


IEditbox Methods

The IEditbox type exposes the following members.

Methods
 | Name | Description
Public method | Select | Selects a substring of the Text
Top
See Also

Reference

IEditbox Interface


IEditbox.Select Method

IEditboxSelect Method

Selects a substring of the Text

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Select(
    int Start,
    int Length
)
Sub Select (
    Start As Integer,
    Length As Integer
)
void Select(
    int Start,
    int Length
)
abstract Select :
        Start : int *
        Length : int -> unit

Parameters

Start
Type: SystemInt32
The start position to select
Length
Type: SystemInt32
The length to select
See Also

Reference

IEditbox Interface


IEditboxOptions Interface

Interface for returning Editbox options

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditboxOptions
Public Interface IEditboxOptions
public interface class IEditboxOptions
type IEditboxOptions =  interface end

The IEditboxOptions type exposes the following members.

Properties
 | Name | Description
Public property | TabCompleteSuffix | Text to add when tabbing nicks
Public property | TabCompleteSuffixFirstWord | Text to add when tabbing nicks and the nick is the first word in the IEditbox
Top
See Also

Reference

AdiIRCAPI Namespace


IEditboxOptions Properties

The IEditboxOptions type exposes the following members.

Properties
 | Name | Description
Public property | TabCompleteSuffix | Text to add when tabbing nicks
Public property | TabCompleteSuffixFirstWord | Text to add when tabbing nicks and the nick is the first word in the IEditbox
Top
See Also

Reference

IEditboxOptions Interface


IEditboxOptions.TabCompleteSuffix Property

IEditboxOptionsTabCompleteSuffix Property

Text to add when tabbing nicks

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string TabCompleteSuffix { get; set; }
Property TabCompleteSuffix As String
    Get
    Set
property String^ TabCompleteSuffix {
    String^ get ();
    void set (String^ value);
}
abstract TabCompleteSuffix : string with get, set

Property Value

Type: String
See Also

Reference

IEditboxOptions Interface


IEditboxOptions.TabCompleteSuffixFirstWord Property

IEditboxOptionsTabCompleteSuffixFirstWord Property

Text to add when tabbing nicks and the nick is the first word in the IEditbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string TabCompleteSuffixFirstWord { get; set; }
Property TabCompleteSuffixFirstWord As String
    Get
    Set
property String^ TabCompleteSuffixFirstWord {
    String^ get ();
    void set (String^ value);
}
abstract TabCompleteSuffixFirstWord : string with get, set

Property Value

Type: String
See Also

Reference

IEditboxOptions Interface


IMessagesOptions Interface

Interface for returning Messages options

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMessagesOptions
Public Interface IMessagesOptions
public interface class IMessagesOptions
type IMessagesOptions =  interface end

The IMessagesOptions type exposes the following members.

Properties
 | Name | Description
Public property | PrefixCtcp | Returns the nick prefix/syntax to use for CTCP messages
Public property | PrefixEmote | Returns the nick prefix/syntax to use for emote messages
Public property | PrefixSys | Returns the nick prefix/syntax to use for system messages
Public property | PrefixUser | Returns the nick prefix/syntax to use for regular messages
Public property | TimeFormat | Returns the time format to use for messages
Public property | UseTimestamp | Returns whether global timestamps is enabled or disabled
Top
See Also

Reference

AdiIRCAPI Namespace


IMessagesOptions Properties

The IMessagesOptions type exposes the following members.

Properties
 | Name | Description
Public property | PrefixCtcp | Returns the nick prefix/syntax to use for CTCP messages
Public property | PrefixEmote | Returns the nick prefix/syntax to use for emote messages
Public property | PrefixSys | Returns the nick prefix/syntax to use for system messages
Public property | PrefixUser | Returns the nick prefix/syntax to use for regular messages
Public property | TimeFormat | Returns the time format to use for messages
Public property | UseTimestamp | Returns whether global timestamps is enabled or disabled
Top
See Also

Reference

IMessagesOptions Interface


IMessagesOptions.PrefixCtcp Property

IMessagesOptionsPrefixCtcp Property

Returns the nick prefix/syntax to use for CTCP messages

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PrefixCtcp { get; set; }
Property PrefixCtcp As String
    Get
    Set
property String^ PrefixCtcp {
    String^ get ();
    void set (String^ value);
}
abstract PrefixCtcp : string with get, set

Property Value

Type: String
See Also

Reference

IMessagesOptions Interface


IMessagesOptions.PrefixEmote Property

IMessagesOptionsPrefixEmote Property

Returns the nick prefix/syntax to use for emote messages

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PrefixEmote { get; set; }
Property PrefixEmote As String
    Get
    Set
property String^ PrefixEmote {
    String^ get ();
    void set (String^ value);
}
abstract PrefixEmote : string with get, set

Property Value

Type: String
See Also

Reference

IMessagesOptions Interface


IMessagesOptions.PrefixSys Property

IMessagesOptionsPrefixSys Property

Returns the nick prefix/syntax to use for system messages

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PrefixSys { get; set; }
Property PrefixSys As String
    Get
    Set
property String^ PrefixSys {
    String^ get ();
    void set (String^ value);
}
abstract PrefixSys : string with get, set

Property Value

Type: String
See Also

Reference

IMessagesOptions Interface


IMessagesOptions.PrefixUser Property

IMessagesOptionsPrefixUser Property

Returns the nick prefix/syntax to use for regular messages

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PrefixUser { get; set; }
Property PrefixUser As String
    Get
    Set
property String^ PrefixUser {
    String^ get ();
    void set (String^ value);
}
abstract PrefixUser : string with get, set

Property Value

Type: String
See Also

Reference

IMessagesOptions Interface


IMessagesOptions.TimeFormat Property

IMessagesOptionsTimeFormat Property

Returns the time format to use for messages

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string TimeFormat { get; set; }
Property TimeFormat As String
    Get
    Set
property String^ TimeFormat {
    String^ get ();
    void set (String^ value);
}
abstract TimeFormat : string with get, set

Property Value

Type: String
See Also

Reference

IMessagesOptions Interface


IMessagesOptions.UseTimestamp Property

IMessagesOptionsUseTimestamp Property

Returns whether global timestamps is enabled or disabled

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseTimestamp { get; set; }
Property UseTimestamp As Boolean
    Get
    Set
property bool UseTimestamp {
    bool get ();
    void set (bool value);
}
abstract UseTimestamp : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMessagesOptions Interface


Invite Delegate

Delegate gets called when a user on IChannel revices an invite

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Invite(
    IServer Server,
    IChannel Channel,
    IUser User,
    out EatData Return
)
Public Delegate Sub Invite (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Invite(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    [OutAttribute] EatData% Return
)
type Invite =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


IPlugin Interface

Inherit from this class in your plugin, e.g class MyPlugin : IPlugin

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPlugin
Public Interface IPlugin
public interface class IPlugin
type IPlugin =  interface end

The IPlugin type exposes the following members.

Properties
 | Name | Description
Public property | Author | Get/Set your name/nick
Public property | Description | Get/Set plugin description
Public property | Email | Your email for support, optional, set to "" if you dont want to provide a email.
Public property | Host | Returns current plugin manager
Public property | Name | Get/Set plugin name
Public property | Tools | Returns ITools reference
Public property | Version | Get/Set plugin version
Top
Methods
 | Name | Description
Public method | Dispose | Called when plugin is unloaded
Public method | Initialize | Called when plugin is loaded
Top
See Also

Reference

AdiIRCAPI Namespace


IPlugin Properties

The IPlugin type exposes the following members.

Properties
 | Name | Description
Public property | Author | Get/Set your name/nick
Public property | Description | Get/Set plugin description
Public property | Email | Your email for support, optional, set to "" if you dont want to provide a email.
Public property | Host | Returns current plugin manager
Public property | Name | Get/Set plugin name
Public property | Tools | Returns ITools reference
Public property | Version | Get/Set plugin version
Top
See Also

Reference

IPlugin Interface


IPlugin.Author Property

IPluginAuthor Property

Get/Set your name/nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Author { get; }
ReadOnly Property Author As String
    Get
property String^ Author {
    String^ get ();
}
abstract Author : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface


IPlugin.Description Property

IPluginDescription Property

Get/Set plugin description

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface


IPlugin.Email Property

IPluginEmail Property

Your email for support, optional, set to "" if you dont want to provide a email.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Email { get; }
ReadOnly Property Email As String
    Get
property String^ Email {
    String^ get ();
}
abstract Email : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface


IPlugin.Host Property

IPluginHost Property

Returns current plugin manager

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IPluginHost Host { get; set; }
Property Host As IPluginHost
    Get
    Set
property IPluginHost^ Host {
    IPluginHost^ get ();
    void set (IPluginHost^ value);
}
abstract Host : IPluginHost with get, set

Property Value

Type: IPluginHost
See Also

Reference

IPlugin Interface


IPlugin.Name Property

IPluginName Property

Get/Set plugin name

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface


IPlugin.Tools Property

IPluginTools Property

Returns ITools reference

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ITools Tools { get; set; }
Property Tools As ITools
    Get
    Set
property ITools^ Tools {
    ITools^ get ();
    void set (ITools^ value);
}
abstract Tools : ITools with get, set

Property Value

Type: ITools
See Also

Reference

IPlugin Interface


IPlugin.Version Property

IPluginVersion Property

Get/Set plugin version

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Version { get; }
ReadOnly Property Version As String
    Get
property String^ Version {
    String^ get ();
}
abstract Version : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface


IPlugin Methods

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Called when plugin is unloaded
Public method | Initialize | Called when plugin is loaded
Top
See Also

Reference

IPlugin Interface


IPlugin.Dispose Method

IPluginDispose Method

Called when plugin is unloaded

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Dispose()
Sub Dispose
void Dispose()
abstract Dispose : unit -> unit
See Also

Reference

IPlugin Interface


IPlugin.Initialize Method

IPluginInitialize Method

Called when plugin is loaded

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialize()
Sub Initialize
void Initialize()
abstract Initialize : unit -> unit
See Also

Reference

IPlugin Interface


IPluginHost Interface

Overall plugin manager

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginHost
Public Interface IPluginHost
public interface class IPluginHost
type IPluginHost =  interface end

The IPluginHost type exposes the following members.

Properties
 | Name | Description
Public property | ActiveIWindow | Returns the current active IWindow
Public property | ActiveWindow | Obsolete. Returns the current active window
Public property | ConfigFolder | Returns the AdiIRC config folder.
Public property | EditboxOptions | IEditboxOptions
Public property | GetServers | Get a list of IServers
Public property | GetVariables | Returns a list of global variables which are saved across sessions
Public property | GetWindows | Get a list of IWindows
Public property | MessagesOptions | IMessagesOptions
Public property | ProgramFolder | Returns the AdiIRC program folder.
Top
Methods
 | Name | Description
Public method | Evaluate | Evaluates identifiers in a script line
Public method | HookCommand | Use this to add /commands, you can then suscribe to OnCommand to get data from this command
Public method | NotifyUser(String) | Use this to show information to the user. Show in currently active window
Public method | NotifyUser(Object, String) | Use this to show information to the user. Shows in the specified window of any type. Returns if the message was shown
Public method | NotifyUser(IChannel, String) | Use this to show information to the user. Shows in IChannel window Returns if the message was shown
Public method | NotifyUser(IServer, String) | Use this to show information to the user. Shows in IServer window. Returns if the message was shown
Public method | NotifyUser(IUser, String) | Use this to show information to the user. Shows in IUser window Returns if the message was shown
Public method | SendCommand | Send a /command to a Window, window can be IServer, IChannel or IUser
Public method | SendFakeRaw | Sends raw data to the client IServer, use this to fake messages E.g when you want to replace something in a PRIVMSG
Public method | SendRaw | Sends raw data to the IServer
Public method | SendRawData | Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when this messages are sent.
Public method | SystemUptime | Returns System Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.
Public method | UnHookCommand | Remove a /command, you have defined.
Public method | Uptime | Returns AdiIRC Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.
Top
Events
 | Name | Description
Public event | OnChannelNotice | Delegate gets called when a IChannel recives a notice
Public event | OnCommand | Delegate gets called when your user types a command Window can be IServer (server window), IChannel (channel window), IUser (private window)
Public event | OnConnect | Delegate gets called when a IServer connects
Public event | OnDisconnect | Delegate gets called when a IServer disconnects
Public event | OnEditboxKeyDown | Delegate gets called when a key is pressed down in a Editbox
Public event | OnGetData | Delegate gets called when a IServer retrives raw data
Public event | OnIdentifier | Delegate gets called when the command is called as a $identifier in a script Window can be IServer (server window), IChannel (channel window), IUser (private window)
Public event | OnInvite | Delegate gets called when a user on IChannel revices an invite
Public event | OnJoin | Delegate gets called when a IUser joines a IChannel
Public event | OnKick | Delegate gets called when a IUser is kicked from IChannel
Public event | OnMenu | Delegate gets called when a menu is opened
Public event | OnMessage | Delegate gets called when a IChannel revices a message
Public event | OnMode | Delegate gets called when a IChannel revices a mode
Public event | OnNick | Delegate gets called when a IUser change nick
Public event | OnOptionsChanged | Delegate gets called when the user changes a options and the config file is reloaded.
Public event | OnPart | Delegate gets called when a IUser parts a IChannel
Public event | OnPrivateMessage | Delegate gets called when your IUser recives a private message
Public event | OnQuit | Delegate gets called when a IUser quits the IServer
Public event | OnRawData | Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when this messages are sent.
Public event | OnRegistered | Delegate gets called when a IServer is registered
Public event | OnSendData | Delegate gets called when user sends data to the IServer
Public event | OnServerNotice | Delegate gets called when a IServer recives a notice
Public event | OnTopic | Delegate gets called when a IUser changes topic in IChannel
Public event | OnUserInvite | Delegate gets called when your IUser recives an IChannel invite
Public event | OnUserJoin | Delegate gets called when your IUser joines a IChannel
Public event | OnUserKick | Delegate gets called when your IUser is kicked from IChannel
Public event | OnUserMessage | Delegate gets called when your IUser send a message to object object can be either IChannel or IUser
Public event | OnUserMode | Delegate gets called when your IUser revices a umode
Public event | OnUserNick | Delegate gets called when your IUser change nick
Public event | OnUserNotice | Delegate gets called when your IUser recives a notice
Public event | OnUserPart | Delegate gets called when your IUser parts a IChannel
Public event | OnUserQuit | Delegate gets called when your IUser quits the IServer
Top
See Also

Reference

AdiIRCAPI Namespace


IPluginHost Properties

The IPluginHost type exposes the following members.

Properties
 | Name | Description
Public property | ActiveIWindow | Returns the current active IWindow
Public property | ActiveWindow | Obsolete. Returns the current active window
Public property | ConfigFolder | Returns the AdiIRC config folder.
Public property | EditboxOptions | IEditboxOptions
Public property | GetServers | Get a list of IServers
Public property | GetVariables | Returns a list of global variables which are saved across sessions
Public property | GetWindows | Get a list of IWindows
Public property | MessagesOptions | IMessagesOptions
Public property | ProgramFolder | Returns the AdiIRC program folder.
Top
See Also

Reference

IPluginHost Interface


IPluginHost.ActiveIWindow Property

IPluginHostActiveIWindow Property

Returns the current active IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IWindow ActiveIWindow { get; }
ReadOnly Property ActiveIWindow As IWindow
    Get
property IWindow^ ActiveIWindow {
    IWindow^ get ();
}
abstract ActiveIWindow : IWindow with get

Property Value

Type: IWindow
See Also

Reference

IPluginHost Interface


IPluginHost.ActiveWindow Property

IPluginHostActiveWindow Property

Note: This API is now obsolete.

Returns the current active window

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Method1 is deprecated, please use ActiveIWindow instead.")]
Object ActiveWindow { get; }
<ObsoleteAttribute("Method1 is deprecated, please use ActiveIWindow instead.")>
ReadOnly Property ActiveWindow As Object
    Get
[ObsoleteAttribute(L"Method1 is deprecated, please use ActiveIWindow instead.")]
property Object^ ActiveWindow {
    Object^ get ();
}
[<ObsoleteAttribute("Method1 is deprecated, please use ActiveIWindow instead.")>]
abstract ActiveWindow : Object with get

Property Value

Type: Object
See Also

Reference

IPluginHost Interface


IPluginHost.ConfigFolder Property

IPluginHostConfigFolder Property

Returns the AdiIRC config folder.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConfigFolder { get; }
ReadOnly Property ConfigFolder As String
    Get
property String^ ConfigFolder {
    String^ get ();
}
abstract ConfigFolder : string with get

Property Value

Type: String
See Also

Reference

IPluginHost Interface


IPluginHost.EditboxOptions Property

IPluginHostEditboxOptions Property

IEditboxOptions

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditboxOptions EditboxOptions { get; }
ReadOnly Property EditboxOptions As IEditboxOptions
    Get
property IEditboxOptions^ EditboxOptions {
    IEditboxOptions^ get ();
}
abstract EditboxOptions : IEditboxOptions with get

Property Value

Type: IEditboxOptions
See Also

Reference

IPluginHost Interface


IPluginHost.GetServers Property

IPluginHostGetServers Property

Get a list of IServers

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetServers { get; }
ReadOnly Property GetServers As ICollection
    Get
property ICollection^ GetServers {
    ICollection^ get ();
}
abstract GetServers : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IPluginHost Interface


IPluginHost.GetVariables Property

IPluginHostGetVariables Property

Returns a list of global variables which are saved across sessions

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetVariables { get; }
ReadOnly Property GetVariables As ICollection
    Get
property ICollection^ GetVariables {
    ICollection^ get ();
}
abstract GetVariables : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IPluginHost Interface


IPluginHost.GetWindows Property

IPluginHostGetWindows Property

Get a list of IWindows

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetWindows { get; }
ReadOnly Property GetWindows As ICollection
    Get
property ICollection^ GetWindows {
    ICollection^ get ();
}
abstract GetWindows : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IPluginHost Interface


IPluginHost.MessagesOptions Property

IPluginHostMessagesOptions Property

IMessagesOptions

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IMessagesOptions MessagesOptions { get; }
ReadOnly Property MessagesOptions As IMessagesOptions
    Get
property IMessagesOptions^ MessagesOptions {
    IMessagesOptions^ get ();
}
abstract MessagesOptions : IMessagesOptions with get

Property Value

Type: IMessagesOptions
See Also

Reference

IPluginHost Interface


IPluginHost.ProgramFolder Property

IPluginHostProgramFolder Property

Returns the AdiIRC program folder.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProgramFolder { get; }
ReadOnly Property ProgramFolder As String
    Get
property String^ ProgramFolder {
    String^ get ();
}
abstract ProgramFolder : string with get

Property Value

Type: String
See Also

Reference

IPluginHost Interface


IPluginHost Methods

The IPluginHost type exposes the following members.

Methods
 | Name | Description
Public method | Evaluate | Evaluates identifiers in a script line
Public method | HookCommand | Use this to add /commands, you can then suscribe to OnCommand to get data from this command
Public method | NotifyUser(String) | Use this to show information to the user. Show in currently active window
Public method | NotifyUser(Object, String) | Use this to show information to the user. Shows in the specified window of any type. Returns if the message was shown
Public method | NotifyUser(IChannel, String) | Use this to show information to the user. Shows in IChannel window Returns if the message was shown
Public method | NotifyUser(IServer, String) | Use this to show information to the user. Shows in IServer window. Returns if the message was shown
Public method | NotifyUser(IUser, String) | Use this to show information to the user. Shows in IUser window Returns if the message was shown
Public method | SendCommand | Send a /command to a Window, window can be IServer, IChannel or IUser
Public method | SendFakeRaw | Sends raw data to the client IServer, use this to fake messages E.g when you want to replace something in a PRIVMSG
Public method | SendRaw | Sends raw data to the IServer
Public method | SendRawData | Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when this messages are sent.
Public method | SystemUptime | Returns System Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.
Public method | UnHookCommand | Remove a /command, you have defined.
Public method | Uptime | Returns AdiIRC Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.
Top
See Also

Reference

IPluginHost Interface


IPluginHost.Evaluate Method

IPluginHostEvaluate Method

Evaluates identifiers in a script line

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Evaluate(
    Object Window,
    string Text,
    string Parameters
)
Function Evaluate (
    Window As Object,
    Text As String,
    Parameters As String
) As String
String^ Evaluate(
    Object^ Window,
    String^ Text,
    String^ Parameters
)
abstract Evaluate :
        Window : Object *
        Text : string *
        Parameters : string -> string

Parameters

Window
Type: SystemObject
Window/server to evaluate on
Text
Type: SystemString
Text to evaluate
Parameters
Type: SystemString
Optional parameters to use for $1-

Return Value

Type: String
The evaluated text
See Also

Reference

IPluginHost Interface


IPluginHost.HookCommand Method

IPluginHostHookCommand Method

Use this to add /commands, you can then suscribe to OnCommand to get data from this command

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HookCommand(
    IPlugin Plugin,
    string Command,
    string HelpSyntax,
    string Description
)
Function HookCommand (
    Plugin As IPlugin,
    Command As String,
    HelpSyntax As String,
    Description As String
) As Boolean
bool HookCommand(
    IPlugin^ Plugin,
    String^ Command,
    String^ HelpSyntax,
    String^ Description
)
abstract HookCommand :
        Plugin : IPlugin *
        Command : string *
        HelpSyntax : string *
        Description : string -> bool

Parameters

Plugin
Type: AdiIRCAPIIPlugin
IPlugin
Command
Type: SystemString
String
HelpSyntax
Type: SystemString
String
Description
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if hooking the command was successful
See Also

Reference

IPluginHost Interface


IPluginHost.NotifyUser Method

IPluginHostNotifyUser Method

Overload List
 | Name | Description
Public method | NotifyUser(String) | Use this to show information to the user. Show in currently active window
Public method | NotifyUser(Object, String) | Use this to show information to the user. Shows in the specified window of any type. Returns if the message was shown
Public method | NotifyUser(IChannel, String) | Use this to show information to the user. Shows in IChannel window Returns if the message was shown
Public method | NotifyUser(IServer, String) | Use this to show information to the user. Shows in IServer window. Returns if the message was shown
Public method | NotifyUser(IUser, String) | Use this to show information to the user. Shows in IUser window Returns if the message was shown
Top
See Also

Reference

IPluginHost Interface


IPluginHost.NotifyUser Method (String)

IPluginHostNotifyUser Method (String)

Use this to show information to the user. Show in currently active window

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NotifyUser(
    string Message
)
Function NotifyUser (
    Message As String
) As Boolean
bool NotifyUser(
    String^ Message
)
abstract NotifyUser :
        Message : string -> bool

Parameters

Message
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the notify was successful
See Also

Reference

IPluginHost Interface
NotifyUser Overload


IPluginHost.NotifyUser Method (Object, String)

IPluginHostNotifyUser Method (Object, String)

Use this to show information to the user. Shows in the specified window of any type. Returns if the message was shown

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NotifyUser(
    Object Window,
    string Message
)
Function NotifyUser (
    Window As Object,
    Message As String
) As Boolean
bool NotifyUser(
    Object^ Window,
    String^ Message
)
abstract NotifyUser :
        Window : Object *
        Message : string -> bool

Parameters

Window
Type: SystemObject
Object
Message
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the notify was successful
See Also

Reference

IPluginHost Interface
NotifyUser Overload


IPluginHost.NotifyUser Method (IChannel, String)

IPluginHostNotifyUser Method (IChannel, String)

Use this to show information to the user. Shows in IChannel window Returns if the message was shown

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NotifyUser(
    IChannel Channel,
    string Message
)
Function NotifyUser (
    Channel As IChannel,
    Message As String
) As Boolean
bool NotifyUser(
    IChannel^ Channel,
    String^ Message
)
abstract NotifyUser :
        Channel : IChannel *
        Message : string -> bool

Parameters

Channel
Type: AdiIRCAPIIChannel
IChannel
Message
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the notify was successful
See Also

Reference

IPluginHost Interface
NotifyUser Overload


IPluginHost.NotifyUser Method (IServer, String)

IPluginHostNotifyUser Method (IServer, String)

Use this to show information to the user. Shows in IServer window. Returns if the message was shown

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NotifyUser(
    IServer Server,
    string Message
)
Function NotifyUser (
    Server As IServer,
    Message As String
) As Boolean
bool NotifyUser(
    IServer^ Server,
    String^ Message
)
abstract NotifyUser :
        Server : IServer *
        Message : string -> bool

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Message
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the notify was successful
See Also

Reference

IPluginHost Interface
NotifyUser Overload


IPluginHost.NotifyUser Method (IUser, String)

IPluginHostNotifyUser Method (IUser, String)

Use this to show information to the user. Shows in IUser window Returns if the message was shown

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NotifyUser(
    IUser User,
    string Message
)
Function NotifyUser (
    User As IUser,
    Message As String
) As Boolean
bool NotifyUser(
    IUser^ User,
    String^ Message
)
abstract NotifyUser :
        User : IUser *
        Message : string -> bool

Parameters

User
Type: AdiIRCAPIIUser
IUser
Message
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the notify was successful
See Also

Reference

IPluginHost Interface
NotifyUser Overload


IPluginHost.SendCommand Method

IPluginHostSendCommand Method

Send a /command to a Window, window can be IServer, IChannel or IUser

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendCommand(
    Object Window,
    string Command,
    string Args
)
Function SendCommand (
    Window As Object,
    Command As String,
    Args As String
) As Boolean
bool SendCommand(
    Object^ Window,
    String^ Command,
    String^ Args
)
abstract SendCommand :
        Window : Object *
        Command : string *
        Args : string -> bool

Parameters

Window
Type: SystemObject
Object
Command
Type: SystemString
String
Args
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IPluginHost Interface


IPluginHost.SendFakeRaw Method

IPluginHostSendFakeRaw Method

Sends raw data to the client IServer, use this to fake messages E.g when you want to replace something in a PRIVMSG

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendFakeRaw(
    IServer Server,
    string Data
)
Function SendFakeRaw (
    Server As IServer,
    Data As String
) As Boolean
bool SendFakeRaw(
    IServer^ Server,
    String^ Data
)
abstract SendFakeRaw :
        Server : IServer *
        Data : string -> bool

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Data
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IPluginHost Interface


IPluginHost.SendRaw Method

IPluginHostSendRaw Method

Sends raw data to the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendRaw(
    IServer Server,
    string Data
)
Function SendRaw (
    Server As IServer,
    Data As String
) As Boolean
bool SendRaw(
    IServer^ Server,
    String^ Data
)
abstract SendRaw :
        Server : IServer *
        Data : string -> bool

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Data
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IPluginHost Interface


IPluginHost.SendRawData Method

IPluginHostSendRawData Method

Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when this messages are sent.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendRawData(
    IServer Server,
    byte[] Data
)
Function SendRawData (
    Server As IServer,
    Data As Byte()
) As Boolean
bool SendRawData(
    IServer^ Server,
    array<unsigned char>^ Data
)
abstract SendRawData :
        Server : IServer *
        Data : byte[] -> bool

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Data
Type: SystemByte
Byte[]

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IPluginHost Interface


IPluginHost.SystemUptime Method

IPluginHostSystemUptime Method

Returns System Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string SystemUptime(
    int type
)
Function SystemUptime (
    type As Integer
) As String
String^ SystemUptime(
    int type
)
abstract SystemUptime :
        type : int -> string

Parameters

type
Type: SystemInt32

[Missing <param name="type"/> documentation for "M:AdiIRCAPI.IPluginHost.SystemUptime(System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:AdiIRCAPI.IPluginHost.SystemUptime(System.Int32)"]

See Also

Reference

IPluginHost Interface


IPluginHost.UnHookCommand Method

IPluginHostUnHookCommand Method

Remove a /command, you have defined.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnHookCommand(
    IPlugin Plugin,
    string Command
)
Function UnHookCommand (
    Plugin As IPlugin,
    Command As String
) As Boolean
bool UnHookCommand(
    IPlugin^ Plugin,
    String^ Command
)
abstract UnHookCommand :
        Plugin : IPlugin *
        Command : string -> bool

Parameters

Plugin
Type: AdiIRCAPIIPlugin
IPlugin
Command
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if unhooking the command was successful
See Also

Reference

IPluginHost Interface


IPluginHost.Uptime Method

IPluginHostUptime Method

Returns AdiIRC Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Uptime(
    int type
)
Function Uptime (
    type As Integer
) As String
String^ Uptime(
    int type
)
abstract Uptime :
        type : int -> string

Parameters

type
Type: SystemInt32

[Missing <param name="type"/> documentation for "M:AdiIRCAPI.IPluginHost.Uptime(System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:AdiIRCAPI.IPluginHost.Uptime(System.Int32)"]

See Also

Reference

IPluginHost Interface


IPluginHost Events

The IPluginHost type exposes the following members.

Events
 | Name | Description
Public event | OnChannelNotice | Delegate gets called when a IChannel recives a notice
Public event | OnCommand | Delegate gets called when your user types a command Window can be IServer (server window), IChannel (channel window), IUser (private window)
Public event | OnConnect | Delegate gets called when a IServer connects
Public event | OnDisconnect | Delegate gets called when a IServer disconnects
Public event | OnEditboxKeyDown | Delegate gets called when a key is pressed down in a Editbox
Public event | OnGetData | Delegate gets called when a IServer retrives raw data
Public event | OnIdentifier | Delegate gets called when the command is called as a $identifier in a script Window can be IServer (server window), IChannel (channel window), IUser (private window)
Public event | OnInvite | Delegate gets called when a user on IChannel revices an invite
Public event | OnJoin | Delegate gets called when a IUser joines a IChannel
Public event | OnKick | Delegate gets called when a IUser is kicked from IChannel
Public event | OnMenu | Delegate gets called when a menu is opened
Public event | OnMessage | Delegate gets called when a IChannel revices a message
Public event | OnMode | Delegate gets called when a IChannel revices a mode
Public event | OnNick | Delegate gets called when a IUser change nick
Public event | OnOptionsChanged | Delegate gets called when the user changes a options and the config file is reloaded.
Public event | OnPart | Delegate gets called when a IUser parts a IChannel
Public event | OnPrivateMessage | Delegate gets called when your IUser recives a private message
Public event | OnQuit | Delegate gets called when a IUser quits the IServer
Public event | OnRawData | Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when this messages are sent.
Public event | OnRegistered | Delegate gets called when a IServer is registered
Public event | OnSendData | Delegate gets called when user sends data to the IServer
Public event | OnServerNotice | Delegate gets called when a IServer recives a notice
Public event | OnTopic | Delegate gets called when a IUser changes topic in IChannel
Public event | OnUserInvite | Delegate gets called when your IUser recives an IChannel invite
Public event | OnUserJoin | Delegate gets called when your IUser joines a IChannel
Public event | OnUserKick | Delegate gets called when your IUser is kicked from IChannel
Public event | OnUserMessage | Delegate gets called when your IUser send a message to object object can be either IChannel or IUser
Public event | OnUserMode | Delegate gets called when your IUser revices a umode
Public event | OnUserNick | Delegate gets called when your IUser change nick
Public event | OnUserNotice | Delegate gets called when your IUser recives a notice
Public event | OnUserPart | Delegate gets called when your IUser parts a IChannel
Public event | OnUserQuit | Delegate gets called when your IUser quits the IServer
Top
See Also

Reference

IPluginHost Interface


IPluginHost.OnChannelNotice Event

IPluginHostOnChannelNotice Event

Delegate gets called when a IChannel recives a notice

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event ChannelNotice OnChannelNotice
Event OnChannelNotice As ChannelNotice
 event ChannelNotice^ OnChannelNotice {
    void add (ChannelNotice^ value);
    void remove (ChannelNotice^ value);
}
abstract OnChannelNotice : IEvent<ChannelNotice,
    EventArgs>

Value

Type: AdiIRCAPIChannelNotice
See Also

Reference

IPluginHost Interface


IPluginHost.OnCommand Event

IPluginHostOnCommand Event

Delegate gets called when your user types a command Window can be IServer (server window), IChannel (channel window), IUser (private window)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Command OnCommand
Event OnCommand As Command
 event Command^ OnCommand {
    void add (Command^ value);
    void remove (Command^ value);
}
abstract OnCommand : IEvent<Command,
    EventArgs>

Value

Type: AdiIRCAPICommand
See Also

Reference

IPluginHost Interface


IPluginHost.OnConnect Event

IPluginHostOnConnect Event

Delegate gets called when a IServer connects

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Connect OnConnect
Event OnConnect As Connect
 event Connect^ OnConnect {
    void add (Connect^ value);
    void remove (Connect^ value);
}
abstract OnConnect : IEvent<Connect,
    EventArgs>

Value

Type: AdiIRCAPIConnect
See Also

Reference

IPluginHost Interface


IPluginHost.OnDisconnect Event

IPluginHostOnDisconnect Event

Delegate gets called when a IServer disconnects

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Disconnect OnDisconnect
Event OnDisconnect As Disconnect
 event Disconnect^ OnDisconnect {
    void add (Disconnect^ value);
    void remove (Disconnect^ value);
}
abstract OnDisconnect : IEvent<Disconnect,
    EventArgs>

Value

Type: AdiIRCAPIDisconnect
See Also

Reference

IPluginHost Interface


IPluginHost.OnEditboxKeyDown Event

IPluginHostOnEditboxKeyDown Event

Delegate gets called when a key is pressed down in a Editbox

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event EditboxKeyDown OnEditboxKeyDown
Event OnEditboxKeyDown As EditboxKeyDown
 event EditboxKeyDown^ OnEditboxKeyDown {
    void add (EditboxKeyDown^ value);
    void remove (EditboxKeyDown^ value);
}
abstract OnEditboxKeyDown : IEvent<EditboxKeyDown,
    EventArgs>

Value

Type: AdiIRCAPIEditboxKeyDown
See Also

Reference

IPluginHost Interface


IPluginHost.OnGetData Event

IPluginHostOnGetData Event

Delegate gets called when a IServer retrives raw data

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event GetData OnGetData
Event OnGetData As GetData
 event GetData^ OnGetData {
    void add (GetData^ value);
    void remove (GetData^ value);
}
abstract OnGetData : IEvent<GetData,
    EventArgs>

Value

Type: AdiIRCAPIGetData
See Also

Reference

IPluginHost Interface


IPluginHost.OnIdentifier Event

IPluginHostOnIdentifier Event

Delegate gets called when the command is called as a $identifier in a script Window can be IServer (server window), IChannel (channel window), IUser (private window)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Identifier OnIdentifier
Event OnIdentifier As Identifier
 event Identifier^ OnIdentifier {
    void add (Identifier^ value);
    void remove (Identifier^ value);
}
abstract OnIdentifier : IEvent<Identifier,
    EventArgs>

Value

Type: AdiIRCAPIIdentifier
See Also

Reference

IPluginHost Interface


IPluginHost.OnInvite Event

IPluginHostOnInvite Event

Delegate gets called when a user on IChannel revices an invite

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Invite OnInvite
Event OnInvite As Invite
 event Invite^ OnInvite {
    void add (Invite^ value);
    void remove (Invite^ value);
}
abstract OnInvite : IEvent<Invite,
    EventArgs>

Value

Type: AdiIRCAPIInvite
See Also

Reference

IPluginHost Interface


IPluginHost.OnJoin Event

IPluginHostOnJoin Event

Delegate gets called when a IUser joines a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Join OnJoin
Event OnJoin As Join
 event Join^ OnJoin {
    void add (Join^ value);
    void remove (Join^ value);
}
abstract OnJoin : IEvent<Join,
    EventArgs>

Value

Type: AdiIRCAPIJoin
See Also

Reference

IPluginHost Interface


IPluginHost.OnKick Event

IPluginHostOnKick Event

Delegate gets called when a IUser is kicked from IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Kick OnKick
Event OnKick As Kick
 event Kick^ OnKick {
    void add (Kick^ value);
    void remove (Kick^ value);
}
abstract OnKick : IEvent<Kick,
    EventArgs>

Value

Type: AdiIRCAPIKick
See Also

Reference

IPluginHost Interface


IPluginHost.OnMenu Event

IPluginHostOnMenu Event

Delegate gets called when a menu is opened

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Menu OnMenu
Event OnMenu As Menu
 event Menu^ OnMenu {
    void add (Menu^ value);
    void remove (Menu^ value);
}
abstract OnMenu : IEvent<Menu,
    EventArgs>

Value

Type: AdiIRCAPIMenu
See Also

Reference

IPluginHost Interface


IPluginHost.OnMessage Event

IPluginHostOnMessage Event

Delegate gets called when a IChannel revices a message

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Message OnMessage
Event OnMessage As Message
 event Message^ OnMessage {
    void add (Message^ value);
    void remove (Message^ value);
}
abstract OnMessage : IEvent<Message,
    EventArgs>

Value

Type: AdiIRCAPIMessage
See Also

Reference

IPluginHost Interface


IPluginHost.OnMode Event

IPluginHostOnMode Event

Delegate gets called when a IChannel revices a mode

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Mode OnMode
Event OnMode As Mode
 event Mode^ OnMode {
    void add (Mode^ value);
    void remove (Mode^ value);
}
abstract OnMode : IEvent<Mode,
    EventArgs>

Value

Type: AdiIRCAPIMode
See Also

Reference

IPluginHost Interface


IPluginHost.OnNick Event

IPluginHostOnNick Event

Delegate gets called when a IUser change nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Nick OnNick
Event OnNick As Nick
 event Nick^ OnNick {
    void add (Nick^ value);
    void remove (Nick^ value);
}
abstract OnNick : IEvent<Nick,
    EventArgs>

Value

Type: AdiIRCAPINick
See Also

Reference

IPluginHost Interface


IPluginHost.OnOptionsChanged Event

IPluginHostOnOptionsChanged Event

Delegate gets called when the user changes a options and the config file is reloaded.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event OptionsChanged OnOptionsChanged
Event OnOptionsChanged As OptionsChanged
 event OptionsChanged^ OnOptionsChanged {
    void add (OptionsChanged^ value);
    void remove (OptionsChanged^ value);
}
abstract OnOptionsChanged : IEvent<OptionsChanged,
    EventArgs>

Value

Type: AdiIRCAPIOptionsChanged
See Also

Reference

IPluginHost Interface


IPluginHost.OnPart Event

IPluginHostOnPart Event

Delegate gets called when a IUser parts a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Part OnPart
Event OnPart As Part
 event Part^ OnPart {
    void add (Part^ value);
    void remove (Part^ value);
}
abstract OnPart : IEvent<Part,
    EventArgs>

Value

Type: AdiIRCAPIPart
See Also

Reference

IPluginHost Interface


IPluginHost.OnPrivateMessage Event

IPluginHostOnPrivateMessage Event

Delegate gets called when your IUser recives a private message

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event PrivateMessage OnPrivateMessage
Event OnPrivateMessage As PrivateMessage
 event PrivateMessage^ OnPrivateMessage {
    void add (PrivateMessage^ value);
    void remove (PrivateMessage^ value);
}
abstract OnPrivateMessage : IEvent<PrivateMessage,
    EventArgs>

Value

Type: AdiIRCAPIPrivateMessage
See Also

Reference

IPluginHost Interface


IPluginHost.OnQuit Event

IPluginHostOnQuit Event

Delegate gets called when a IUser quits the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Quit OnQuit
Event OnQuit As Quit
 event Quit^ OnQuit {
    void add (Quit^ value);
    void remove (Quit^ value);
}
abstract OnQuit : IEvent<Quit,
    EventArgs>

Value

Type: AdiIRCAPIQuit
See Also

Reference

IPluginHost Interface


IPluginHost.OnRawData Event

IPluginHostOnRawData Event

Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when this messages are sent.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event RawData OnRawData
Event OnRawData As RawData
 event RawData^ OnRawData {
    void add (RawData^ value);
    void remove (RawData^ value);
}
abstract OnRawData : IEvent<RawData,
    RawDataArgs>

Value

Type: AdiIRCAPIRawData
See Also

Reference

IPluginHost Interface


IPluginHost.OnRegistered Event

IPluginHostOnRegistered Event

Delegate gets called when a IServer is registered

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Registered OnRegistered
Event OnRegistered As Registered
 event Registered^ OnRegistered {
    void add (Registered^ value);
    void remove (Registered^ value);
}
abstract OnRegistered : IEvent<Registered,
    EventArgs>

Value

Type: AdiIRCAPIRegistered
See Also

Reference

IPluginHost Interface


IPluginHost.OnSendData Event

IPluginHostOnSendData Event

Delegate gets called when user sends data to the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event SendData OnSendData
Event OnSendData As SendData
 event SendData^ OnSendData {
    void add (SendData^ value);
    void remove (SendData^ value);
}
abstract OnSendData : IEvent<SendData,
    EventArgs>

Value

Type: AdiIRCAPISendData
See Also

Reference

IPluginHost Interface


IPluginHost.OnServerNotice Event

IPluginHostOnServerNotice Event

Delegate gets called when a IServer recives a notice

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event ServerNotice OnServerNotice
Event OnServerNotice As ServerNotice
 event ServerNotice^ OnServerNotice {
    void add (ServerNotice^ value);
    void remove (ServerNotice^ value);
}
abstract OnServerNotice : IEvent<ServerNotice,
    EventArgs>

Value

Type: AdiIRCAPIServerNotice
See Also

Reference

IPluginHost Interface


IPluginHost.OnTopic Event

IPluginHostOnTopic Event

Delegate gets called when a IUser changes topic in IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event Topic OnTopic
Event OnTopic As Topic
 event Topic^ OnTopic {
    void add (Topic^ value);
    void remove (Topic^ value);
}
abstract OnTopic : IEvent<Topic,
    EventArgs>

Value

Type: AdiIRCAPITopic
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserInvite Event

IPluginHostOnUserInvite Event

Delegate gets called when your IUser recives an IChannel invite

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserInvite OnUserInvite
Event OnUserInvite As UserInvite
 event UserInvite^ OnUserInvite {
    void add (UserInvite^ value);
    void remove (UserInvite^ value);
}
abstract OnUserInvite : IEvent<UserInvite,
    EventArgs>

Value

Type: AdiIRCAPIUserInvite
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserJoin Event

IPluginHostOnUserJoin Event

Delegate gets called when your IUser joines a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserJoin OnUserJoin
Event OnUserJoin As UserJoin
 event UserJoin^ OnUserJoin {
    void add (UserJoin^ value);
    void remove (UserJoin^ value);
}
abstract OnUserJoin : IEvent<UserJoin,
    EventArgs>

Value

Type: AdiIRCAPIUserJoin
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserKick Event

IPluginHostOnUserKick Event

Delegate gets called when your IUser is kicked from IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserKick OnUserKick
Event OnUserKick As UserKick
 event UserKick^ OnUserKick {
    void add (UserKick^ value);
    void remove (UserKick^ value);
}
abstract OnUserKick : IEvent<UserKick,
    EventArgs>

Value

Type: AdiIRCAPIUserKick
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserMessage Event

IPluginHostOnUserMessage Event

Delegate gets called when your IUser send a message to object object can be either IChannel or IUser

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserMessage OnUserMessage
Event OnUserMessage As UserMessage
 event UserMessage^ OnUserMessage {
    void add (UserMessage^ value);
    void remove (UserMessage^ value);
}
abstract OnUserMessage : IEvent<UserMessage,
    EventArgs>

Value

Type: AdiIRCAPIUserMessage
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserMode Event

IPluginHostOnUserMode Event

Delegate gets called when your IUser revices a umode

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserMode OnUserMode
Event OnUserMode As UserMode
 event UserMode^ OnUserMode {
    void add (UserMode^ value);
    void remove (UserMode^ value);
}
abstract OnUserMode : IEvent<UserMode,
    EventArgs>

Value

Type: AdiIRCAPIUserMode
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserNick Event

IPluginHostOnUserNick Event

Delegate gets called when your IUser change nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserNick OnUserNick
Event OnUserNick As UserNick
 event UserNick^ OnUserNick {
    void add (UserNick^ value);
    void remove (UserNick^ value);
}
abstract OnUserNick : IEvent<UserNick,
    EventArgs>

Value

Type: AdiIRCAPIUserNick
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserNotice Event

IPluginHostOnUserNotice Event

Delegate gets called when your IUser recives a notice

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserNotice OnUserNotice
Event OnUserNotice As UserNotice
 event UserNotice^ OnUserNotice {
    void add (UserNotice^ value);
    void remove (UserNotice^ value);
}
abstract OnUserNotice : IEvent<UserNotice,
    EventArgs>

Value

Type: AdiIRCAPIUserNotice
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserPart Event

IPluginHostOnUserPart Event

Delegate gets called when your IUser parts a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserPart OnUserPart
Event OnUserPart As UserPart
 event UserPart^ OnUserPart {
    void add (UserPart^ value);
    void remove (UserPart^ value);
}
abstract OnUserPart : IEvent<UserPart,
    EventArgs>

Value

Type: AdiIRCAPIUserPart
See Also

Reference

IPluginHost Interface


IPluginHost.OnUserQuit Event

IPluginHostOnUserQuit Event

Delegate gets called when your IUser quits the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
event UserQuit OnUserQuit
Event OnUserQuit As UserQuit
 event UserQuit^ OnUserQuit {
    void add (UserQuit^ value);
    void remove (UserQuit^ value);
}
abstract OnUserQuit : IEvent<UserQuit,
    EventArgs>

Value

Type: AdiIRCAPIUserQuit
See Also

Reference

IPluginHost Interface


IServer Interface

Represents a server object

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IServer
Public Interface IServer
public interface class IServer
type IServer =  interface end

The IServer type exposes the following members.

Properties
 | Name | Description
Public property | Away | Returns whether ia away on this IServer
Public property | AwayMessage | Returns the away message on this IServer
Public property | AwayTime | Returns the time user went away on this IServer (UTC time)
Public property | BanLength | Max ban list count on this IServer (retrieved from 005)
Public property | BanType | Returns the custom default BanType on this IServer, if any
Public property | ChannelModes | Returns the available channel modes on this IServer (retrieved from 005 chanmodes=)
Public property | ChannelModesWithArgs | Returns the available channel modes which can have an argument on this IServer (retrieved from 005 chanmodes=)
Public property | ChannelModesWithRequiredArgs | Returns the available channel modes which must have an argument on this IServer (retrieved from 005 chanmodes=)
Public property | ChannelPrefix | Get supported channelprefixes on this IServer
Public property | ConnectedAt | Returns the time user connected to this IServer (UTC time)
Public property | ConnectError | Returns whether the last connection attempt failed on the IServer
Public property | ConnectionId | Returns the connection id on this IServer
Public property | ConnectionSuccess | Returns whether the last connect attempt was a success
Public property | DelayBetweenJoins | Returns number of seconds to delay between each channel join on this IServer
Public property | DelayJoin | Returns number of seconds to delay joining channels on this IServer
Public property | Editbox | Returns the IEditbox for the IServer window (can be null)
Public property | Encoding | Get the encoding used on this IServer
Public property | Error | Returns whether the error type of the last connections error (0 = no error)
Public property | ExceptLength | Max except list count on this IServer (retrieved from 005)
Public property | ExternalHost | Get the external host discovered from this IServer
Public property | ExternalIp | Get the external Ip discovered from this IServer
Public property | GetChannels | Get a collection of IChannels in this IServer
Public property | GetUsers | Get a collection of IUsers in this IServer
Public property | Host | Get the IServer hostname
Public property | HostIP | Get the IServer IP address
Public property | HostTarget | Get the IServer target hostname entered in the Serverlist or /server
Public property | IdleTime | Returns the time user last sent a message to this IServer (UTC time)
Public property | InviteLength | Max invite list count on this IServer (retrieved from 005)
Public property | IsConnected | Returns whether the IServer is connected
Public property | IsConnecting | Returns whether the IServer is connecting
Public property | IsLoggingOn | Returns whether the user is logging on IServer
Public property | IsReconnecting | Returns whether the IServer is re-connecting
Public property | IsRegistered | Returns whether the user is logged on to the IServer
Public property | IsUsingSSL | Get whether IServer is using SSL secure connection
Public property | Lag | Get server lag
Public property | LastQuitMessage | Returns the last QuitMessage sent on this IServer
Public property | LoginMethod | Returns the loginmethod for this IServer
Public property | ModesLength | Returns number of modes which can be in one MODE request on this IServer
Public property | Name | Get the IServer name
Public property | Network | Get the IServer network name
Public property | NetworkLabel | Network label for this IServer
Public property | Nick | Get current nick
Public property | Port | Get the IServer port
Public property | PrefNick | Get prefered nick
Public property | PrefNick2 | Get prefered alternate nick
Public property | QuietLength | Max quiet list count on this IServer (retrieved from 005)
Public property | QuitMessage | Returns custom QuitMessage on this IServer, if enabled
Public property | RealName | Get realname
Public property | RegainNick | Returs or set whether to use RegainNick on this IServer
Public property | TopicLength | Max topic length on this IServer (retrieved from 005)
Public property | UseGlobalQuitMessage | Returns whether the the IServer uses the global or custom quit message
Public property | UseNetworkLabel | Returns whether to use network label on this IServer
Public property | UserNick | Get usernick
Public property | UserPrefix | Get supported userprefix characters on this IServer
Public property | UserPrefixChars | Get supported userprefix letters on this IServer
Public property | Window | returns the IWindow associated with this IServer
Top
Methods
 | Name | Description
Public method | Connect | Connect this IServer if it's not connected
Public method | Disconnect | Disconnect this IServer if it's connected
Public method | FindChannel | Finds the matching IChannel.
Public method | FindUser | Finds the matching User.
Public method | SendFakeRaw | Sends raw data to the client IServer, use this to fake messages E.g when you want to replace something in a PRIVMSG
Public method | SendRaw | Sends raw data to the IServer
Public method | SendRawData | Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when these messages are sent.
Public method | Uptime | Returns Server Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.
Top
See Also

Reference

AdiIRCAPI Namespace


IServer Properties

The IServer type exposes the following members.

Properties
 | Name | Description
Public property | Away | Returns whether ia away on this IServer
Public property | AwayMessage | Returns the away message on this IServer
Public property | AwayTime | Returns the time user went away on this IServer (UTC time)
Public property | BanLength | Max ban list count on this IServer (retrieved from 005)
Public property | BanType | Returns the custom default BanType on this IServer, if any
Public property | ChannelModes | Returns the available channel modes on this IServer (retrieved from 005 chanmodes=)
Public property | ChannelModesWithArgs | Returns the available channel modes which can have an argument on this IServer (retrieved from 005 chanmodes=)
Public property | ChannelModesWithRequiredArgs | Returns the available channel modes which must have an argument on this IServer (retrieved from 005 chanmodes=)
Public property | ChannelPrefix | Get supported channelprefixes on this IServer
Public property | ConnectedAt | Returns the time user connected to this IServer (UTC time)
Public property | ConnectError | Returns whether the last connection attempt failed on the IServer
Public property | ConnectionId | Returns the connection id on this IServer
Public property | ConnectionSuccess | Returns whether the last connect attempt was a success
Public property | DelayBetweenJoins | Returns number of seconds to delay between each channel join on this IServer
Public property | DelayJoin | Returns number of seconds to delay joining channels on this IServer
Public property | Editbox | Returns the IEditbox for the IServer window (can be null)
Public property | Encoding | Get the encoding used on this IServer
Public property | Error | Returns whether the error type of the last connections error (0 = no error)
Public property | ExceptLength | Max except list count on this IServer (retrieved from 005)
Public property | ExternalHost | Get the external host discovered from this IServer
Public property | ExternalIp | Get the external Ip discovered from this IServer
Public property | GetChannels | Get a collection of IChannels in this IServer
Public property | GetUsers | Get a collection of IUsers in this IServer
Public property | Host | Get the IServer hostname
Public property | HostIP | Get the IServer IP address
Public property | HostTarget | Get the IServer target hostname entered in the Serverlist or /server
Public property | IdleTime | Returns the time user last sent a message to this IServer (UTC time)
Public property | InviteLength | Max invite list count on this IServer (retrieved from 005)
Public property | IsConnected | Returns whether the IServer is connected
Public property | IsConnecting | Returns whether the IServer is connecting
Public property | IsLoggingOn | Returns whether the user is logging on IServer
Public property | IsReconnecting | Returns whether the IServer is re-connecting
Public property | IsRegistered | Returns whether the user is logged on to the IServer
Public property | IsUsingSSL | Get whether IServer is using SSL secure connection
Public property | Lag | Get server lag
Public property | LastQuitMessage | Returns the last QuitMessage sent on this IServer
Public property | LoginMethod | Returns the loginmethod for this IServer
Public property | ModesLength | Returns number of modes which can be in one MODE request on this IServer
Public property | Name | Get the IServer name
Public property | Network | Get the IServer network name
Public property | NetworkLabel | Network label for this IServer
Public property | Nick | Get current nick
Public property | Port | Get the IServer port
Public property | PrefNick | Get prefered nick
Public property | PrefNick2 | Get prefered alternate nick
Public property | QuietLength | Max quiet list count on this IServer (retrieved from 005)
Public property | QuitMessage | Returns custom QuitMessage on this IServer, if enabled
Public property | RealName | Get realname
Public property | RegainNick | Returs or set whether to use RegainNick on this IServer
Public property | TopicLength | Max topic length on this IServer (retrieved from 005)
Public property | UseGlobalQuitMessage | Returns whether the the IServer uses the global or custom quit message
Public property | UseNetworkLabel | Returns whether to use network label on this IServer
Public property | UserNick | Get usernick
Public property | UserPrefix | Get supported userprefix characters on this IServer
Public property | UserPrefixChars | Get supported userprefix letters on this IServer
Public property | Window | returns the IWindow associated with this IServer
Top
See Also

Reference

IServer Interface


IServer.Away Property

IServerAway Property

Returns whether ia away on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Away { get; }
ReadOnly Property Away As Boolean
    Get
property bool Away {
    bool get ();
}
abstract Away : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.AwayMessage Property

IServerAwayMessage Property

Returns the away message on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string AwayMessage { get; }
ReadOnly Property AwayMessage As String
    Get
property String^ AwayMessage {
    String^ get ();
}
abstract AwayMessage : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.AwayTime Property

IServerAwayTime Property

Returns the time user went away on this IServer (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime AwayTime { get; }
ReadOnly Property AwayTime As DateTime
    Get
property DateTime AwayTime {
    DateTime get ();
}
abstract AwayTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IServer Interface


IServer.BanLength Property

IServerBanLength Property

Max ban list count on this IServer (retrieved from 005)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int BanLength { get; }
ReadOnly Property BanLength As Integer
    Get
property int BanLength {
    int get ();
}
abstract BanLength : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.BanType Property

IServerBanType Property

Returns the custom default BanType on this IServer, if any

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string BanType { get; }
ReadOnly Property BanType As String
    Get
property String^ BanType {
    String^ get ();
}
abstract BanType : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.ChannelModes Property

IServerChannelModes Property

Returns the available channel modes on this IServer (retrieved from 005 chanmodes=)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ChannelModes { get; }
ReadOnly Property ChannelModes As String
    Get
property String^ ChannelModes {
    String^ get ();
}
abstract ChannelModes : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.ChannelModesWithArgs Property

IServerChannelModesWithArgs Property

Returns the available channel modes which can have an argument on this IServer (retrieved from 005 chanmodes=)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection ChannelModesWithArgs { get; }
ReadOnly Property ChannelModesWithArgs As ICollection
    Get
property ICollection^ ChannelModesWithArgs {
    ICollection^ get ();
}
abstract ChannelModesWithArgs : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IServer Interface


IServer.ChannelModesWithRequiredArgs Property

IServerChannelModesWithRequiredArgs Property

Returns the available channel modes which must have an argument on this IServer (retrieved from 005 chanmodes=)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection ChannelModesWithRequiredArgs { get; }
ReadOnly Property ChannelModesWithRequiredArgs As ICollection
    Get
property ICollection^ ChannelModesWithRequiredArgs {
    ICollection^ get ();
}
abstract ChannelModesWithRequiredArgs : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IServer Interface


IServer.ChannelPrefix Property

IServerChannelPrefix Property

Get supported channelprefixes on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ChannelPrefix { get; }
ReadOnly Property ChannelPrefix As String
    Get
property String^ ChannelPrefix {
    String^ get ();
}
abstract ChannelPrefix : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.ConnectedAt Property

IServerConnectedAt Property

Returns the time user connected to this IServer (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime ConnectedAt { get; }
ReadOnly Property ConnectedAt As DateTime
    Get
property DateTime ConnectedAt {
    DateTime get ();
}
abstract ConnectedAt : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IServer Interface


IServer.ConnectError Property

IServerConnectError Property

Returns whether the last connection attempt failed on the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ConnectError { get; }
ReadOnly Property ConnectError As Boolean
    Get
property bool ConnectError {
    bool get ();
}
abstract ConnectError : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.ConnectionId Property

IServerConnectionId Property

Returns the connection id on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConnectionId { get; }
ReadOnly Property ConnectionId As String
    Get
property String^ ConnectionId {
    String^ get ();
}
abstract ConnectionId : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.ConnectionSuccess Property

IServerConnectionSuccess Property

Returns whether the last connect attempt was a success

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ConnectionSuccess { get; }
ReadOnly Property ConnectionSuccess As Boolean
    Get
property bool ConnectionSuccess {
    bool get ();
}
abstract ConnectionSuccess : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.DelayBetweenJoins Property

IServerDelayBetweenJoins Property

Returns number of seconds to delay between each channel join on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int DelayBetweenJoins { get; }
ReadOnly Property DelayBetweenJoins As Integer
    Get
property int DelayBetweenJoins {
    int get ();
}
abstract DelayBetweenJoins : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.DelayJoin Property

IServerDelayJoin Property

Returns number of seconds to delay joining channels on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int DelayJoin { get; }
ReadOnly Property DelayJoin As Integer
    Get
property int DelayJoin {
    int get ();
}
abstract DelayJoin : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.Editbox Property

IServerEditbox Property

Returns the IEditbox for the IServer window (can be null)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditbox Editbox { get; }
ReadOnly Property Editbox As IEditbox
    Get
property IEditbox^ Editbox {
    IEditbox^ get ();
}
abstract Editbox : IEditbox with get

Property Value

Type: IEditbox
See Also

Reference

IServer Interface


IServer.Encoding Property

IServerEncoding Property

Get the encoding used on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
Encoding Encoding { get; }
ReadOnly Property Encoding As Encoding
    Get
property Encoding^ Encoding {
    Encoding^ get ();
}
abstract Encoding : Encoding with get

Property Value

Type: Encoding
See Also

Reference

IServer Interface


IServer.Error Property

IServerError Property

Returns whether the error type of the last connections error (0 = no error)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int Error { get; }
ReadOnly Property Error As Integer
    Get
property int Error {
    int get ();
}
abstract Error : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.ExceptLength Property

IServerExceptLength Property

Max except list count on this IServer (retrieved from 005)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int ExceptLength { get; }
ReadOnly Property ExceptLength As Integer
    Get
property int ExceptLength {
    int get ();
}
abstract ExceptLength : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.ExternalHost Property

IServerExternalHost Property

Get the external host discovered from this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExternalHost { get; }
ReadOnly Property ExternalHost As String
    Get
property String^ ExternalHost {
    String^ get ();
}
abstract ExternalHost : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.ExternalIp Property

IServerExternalIp Property

Get the external Ip discovered from this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExternalIp { get; }
ReadOnly Property ExternalIp As String
    Get
property String^ ExternalIp {
    String^ get ();
}
abstract ExternalIp : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.GetChannels Property

IServerGetChannels Property

Get a collection of IChannels in this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetChannels { get; }
ReadOnly Property GetChannels As ICollection
    Get
property ICollection^ GetChannels {
    ICollection^ get ();
}
abstract GetChannels : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IServer Interface


IServer.GetUsers Property

IServerGetUsers Property

Get a collection of IUsers in this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetUsers { get; }
ReadOnly Property GetUsers As ICollection
    Get
property ICollection^ GetUsers {
    ICollection^ get ();
}
abstract GetUsers : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IServer Interface


IServer.Host Property

IServerHost Property

Get the IServer hostname

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Host { get; }
ReadOnly Property Host As String
    Get
property String^ Host {
    String^ get ();
}
abstract Host : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.HostIP Property

IServerHostIP Property

Get the IServer IP address

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IPAddress HostIP { get; }
ReadOnly Property HostIP As IPAddress
    Get
property IPAddress^ HostIP {
    IPAddress^ get ();
}
abstract HostIP : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

IServer Interface


IServer.HostTarget Property

IServerHostTarget Property

Get the IServer target hostname entered in the Serverlist or /server

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string HostTarget { get; }
ReadOnly Property HostTarget As String
    Get
property String^ HostTarget {
    String^ get ();
}
abstract HostTarget : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.IdleTime Property

IServerIdleTime Property

Returns the time user last sent a message to this IServer (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime IdleTime { get; }
ReadOnly Property IdleTime As DateTime
    Get
property DateTime IdleTime {
    DateTime get ();
}
abstract IdleTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IServer Interface


IServer.InviteLength Property

IServerInviteLength Property

Max invite list count on this IServer (retrieved from 005)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int InviteLength { get; }
ReadOnly Property InviteLength As Integer
    Get
property int InviteLength {
    int get ();
}
abstract InviteLength : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.IsConnected Property

IServerIsConnected Property

Returns whether the IServer is connected

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsConnected { get; }
ReadOnly Property IsConnected As Boolean
    Get
property bool IsConnected {
    bool get ();
}
abstract IsConnected : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.IsConnecting Property

IServerIsConnecting Property

Returns whether the IServer is connecting

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsConnecting { get; }
ReadOnly Property IsConnecting As Boolean
    Get
property bool IsConnecting {
    bool get ();
}
abstract IsConnecting : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.IsLoggingOn Property

IServerIsLoggingOn Property

Returns whether the user is logging on IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLoggingOn { get; }
ReadOnly Property IsLoggingOn As Boolean
    Get
property bool IsLoggingOn {
    bool get ();
}
abstract IsLoggingOn : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.IsReconnecting Property

IServerIsReconnecting Property

Returns whether the IServer is re-connecting

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsReconnecting { get; }
ReadOnly Property IsReconnecting As Boolean
    Get
property bool IsReconnecting {
    bool get ();
}
abstract IsReconnecting : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.IsRegistered Property

IServerIsRegistered Property

Returns whether the user is logged on to the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsRegistered { get; }
ReadOnly Property IsRegistered As Boolean
    Get
property bool IsRegistered {
    bool get ();
}
abstract IsRegistered : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.IsUsingSSL Property

IServerIsUsingSSL Property

Get whether IServer is using SSL secure connection

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUsingSSL { get; }
ReadOnly Property IsUsingSSL As Boolean
    Get
property bool IsUsingSSL {
    bool get ();
}
abstract IsUsingSSL : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.Lag Property

IServerLag Property

Get server lag

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
TimeSpan Lag { get; }
ReadOnly Property Lag As TimeSpan
    Get
property TimeSpan Lag {
    TimeSpan get ();
}
abstract Lag : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IServer Interface


IServer.LastQuitMessage Property

IServerLastQuitMessage Property

Returns the last QuitMessage sent on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string LastQuitMessage { get; }
ReadOnly Property LastQuitMessage As String
    Get
property String^ LastQuitMessage {
    String^ get ();
}
abstract LastQuitMessage : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.LoginMethod Property

IServerLoginMethod Property

Returns the loginmethod for this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int LoginMethod { get; }
ReadOnly Property LoginMethod As Integer
    Get
property int LoginMethod {
    int get ();
}
abstract LoginMethod : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.ModesLength Property

IServerModesLength Property

Returns number of modes which can be in one MODE request on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int ModesLength { get; }
ReadOnly Property ModesLength As Integer
    Get
property int ModesLength {
    int get ();
}
abstract ModesLength : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.Name Property

IServerName Property

Get the IServer name

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.Network Property

IServerNetwork Property

Get the IServer network name

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Network { get; }
ReadOnly Property Network As String
    Get
property String^ Network {
    String^ get ();
}
abstract Network : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.NetworkLabel Property

IServerNetworkLabel Property

Network label for this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string NetworkLabel { get; }
ReadOnly Property NetworkLabel As String
    Get
property String^ NetworkLabel {
    String^ get ();
}
abstract NetworkLabel : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.Nick Property

IServerNick Property

Get current nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Nick { get; }
ReadOnly Property Nick As String
    Get
property String^ Nick {
    String^ get ();
}
abstract Nick : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.Port Property

IServerPort Property

Get the IServer port

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int Port { get; }
ReadOnly Property Port As Integer
    Get
property int Port {
    int get ();
}
abstract Port : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.PrefNick Property

IServerPrefNick Property

Get prefered nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PrefNick { get; }
ReadOnly Property PrefNick As String
    Get
property String^ PrefNick {
    String^ get ();
}
abstract PrefNick : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.PrefNick2 Property

IServerPrefNick2 Property

Get prefered alternate nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PrefNick2 { get; }
ReadOnly Property PrefNick2 As String
    Get
property String^ PrefNick2 {
    String^ get ();
}
abstract PrefNick2 : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.QuietLength Property

IServerQuietLength Property

Max quiet list count on this IServer (retrieved from 005)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int QuietLength { get; }
ReadOnly Property QuietLength As Integer
    Get
property int QuietLength {
    int get ();
}
abstract QuietLength : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.QuitMessage Property

IServerQuitMessage Property

Returns custom QuitMessage on this IServer, if enabled

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string QuitMessage { get; }
ReadOnly Property QuitMessage As String
    Get
property String^ QuitMessage {
    String^ get ();
}
abstract QuitMessage : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.RealName Property

IServerRealName Property

Get realname

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string RealName { get; }
ReadOnly Property RealName As String
    Get
property String^ RealName {
    String^ get ();
}
abstract RealName : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.RegainNick Property

IServerRegainNick Property

Returs or set whether to use RegainNick on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegainNick { get; set; }
Property RegainNick As Boolean
    Get
    Set
property bool RegainNick {
    bool get ();
    void set (bool value);
}
abstract RegainNick : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.TopicLength Property

IServerTopicLength Property

Max topic length on this IServer (retrieved from 005)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int TopicLength { get; }
ReadOnly Property TopicLength As Integer
    Get
property int TopicLength {
    int get ();
}
abstract TopicLength : int with get

Property Value

Type: Int32
See Also

Reference

IServer Interface


IServer.UseGlobalQuitMessage Property

IServerUseGlobalQuitMessage Property

Returns whether the the IServer uses the global or custom quit message

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseGlobalQuitMessage { get; }
ReadOnly Property UseGlobalQuitMessage As Boolean
    Get
property bool UseGlobalQuitMessage {
    bool get ();
}
abstract UseGlobalQuitMessage : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.UseNetworkLabel Property

IServerUseNetworkLabel Property

Returns whether to use network label on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseNetworkLabel { get; }
ReadOnly Property UseNetworkLabel As Boolean
    Get
property bool UseNetworkLabel {
    bool get ();
}
abstract UseNetworkLabel : bool with get

Property Value

Type: Boolean
See Also

Reference

IServer Interface


IServer.UserNick Property

IServerUserNick Property

Get usernick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserNick { get; }
ReadOnly Property UserNick As String
    Get
property String^ UserNick {
    String^ get ();
}
abstract UserNick : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.UserPrefix Property

IServerUserPrefix Property

Get supported userprefix characters on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserPrefix { get; }
ReadOnly Property UserPrefix As String
    Get
property String^ UserPrefix {
    String^ get ();
}
abstract UserPrefix : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.UserPrefixChars Property

IServerUserPrefixChars Property

Get supported userprefix letters on this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserPrefixChars { get; }
ReadOnly Property UserPrefixChars As String
    Get
property String^ UserPrefixChars {
    String^ get ();
}
abstract UserPrefixChars : string with get

Property Value

Type: String
See Also

Reference

IServer Interface


IServer.Window Property

IServerWindow Property

returns the IWindow associated with this IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IWindow Window { get; }
ReadOnly Property Window As IWindow
    Get
property IWindow^ Window {
    IWindow^ get ();
}
abstract Window : IWindow with get

Property Value

Type: IWindow
See Also

Reference

IServer Interface


IServer Methods

The IServer type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect this IServer if it's not connected
Public method | Disconnect | Disconnect this IServer if it's connected
Public method | FindChannel | Finds the matching IChannel.
Public method | FindUser | Finds the matching User.
Public method | SendFakeRaw | Sends raw data to the client IServer, use this to fake messages E.g when you want to replace something in a PRIVMSG
Public method | SendRaw | Sends raw data to the IServer
Public method | SendRawData | Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when these messages are sent.
Public method | Uptime | Returns Server Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.
Top
See Also

Reference

IServer Interface


IServer.Connect Method

IServerConnect Method

Connect this IServer if it's not connected

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
See Also

Reference

IServer Interface


IServer.Disconnect Method

IServerDisconnect Method

Disconnect this IServer if it's connected

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

IServer Interface


IServer.FindChannel Method

IServerFindChannel Method

Finds the matching IChannel.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IChannel FindChannel(
    string Name
)
Function FindChannel (
    Name As String
) As IChannel
IChannel^ FindChannel(
    String^ Name
)
abstract FindChannel :
        Name : string -> IChannel

Parameters

Name
Type: SystemString
String

Return Value

Type: IChannel
A IChannel object or null
See Also

Reference

IServer Interface


IServer.FindUser Method

IServerFindUser Method

Finds the matching User.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IUser FindUser(
    string Nick
)
Function FindUser (
    Nick As String
) As IUser
IUser^ FindUser(
    String^ Nick
)
abstract FindUser :
        Nick : string -> IUser

Parameters

Nick
Type: SystemString
String

Return Value

Type: IUser
Aa IUser object, if no user is found, a fake IUser object is created (but not stored).
See Also

Reference

IServer Interface


IServer.SendFakeRaw Method

IServerSendFakeRaw Method

Sends raw data to the client IServer, use this to fake messages E.g when you want to replace something in a PRIVMSG

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendFakeRaw(
    string Data
)
Function SendFakeRaw (
    Data As String
) As Boolean
bool SendFakeRaw(
    String^ Data
)
abstract SendFakeRaw :
        Data : string -> bool

Parameters

Data
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IServer Interface


IServer.SendRaw Method

IServerSendRaw Method

Sends raw data to the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendRaw(
    string Data
)
Function SendRaw (
    Data As String
) As Boolean
bool SendRaw(
    String^ Data
)
abstract SendRaw :
        Data : string -> bool

Parameters

Data
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IServer Interface


IServer.SendRawData Method

IServerSendRawData Method

Sends raw bytes to the IServer, bypasssing any encodings, AdiIRC is not aware when these messages are sent.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SendRawData(
    byte[] Data
)
Function SendRawData (
    Data As Byte()
) As Boolean
bool SendRawData(
    array<unsigned char>^ Data
)
abstract SendRawData :
        Data : byte[] -> bool

Parameters

Data
Type: SystemByte
Byte[]

Return Value

Type: Boolean
True/False depending if the send was successful
See Also

Reference

IServer Interface


IServer.Uptime Method

IServerUptime Method

Returns Server Uptime in milliseconds if type = 1 returns a duration, if type = 2 returns a duration but without seconds, and if type = 3 returns seconds instead of milliseconds.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Uptime(
    int type
)
Function Uptime (
    type As Integer
) As String
String^ Uptime(
    int type
)
abstract Uptime :
        type : int -> string

Parameters

type
Type: SystemInt32

[Missing <param name="type"/> documentation for "M:AdiIRCAPI.IServer.Uptime(System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:AdiIRCAPI.IServer.Uptime(System.Int32)"]

See Also

Reference

IServer Interface


ITextView Interface

Represents a TextView

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextView
Public Interface ITextView
public interface class ITextView
type ITextView =  interface end

The ITextView type exposes the following members.

Properties
 | Name | Description
Public property | Lines | Returns the !TextView buffer lines
Public property | MaxBuffer | Returns the maxmimum buffer for this ITextView
Public property | MaxScrollbar | Returns the maxmimum number the scrollbar can scroll to (wrapped lines)
Public property | ScrollbarPos | Returns the current scrollbar position (wrapped lines)
Public property | UseTimestamp | Returns whether time stamps is enabled for this ITextView buffer
Top
Methods
 | Name | Description
Public method | Add | Adds a line of text to the ITextView buffer Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text
Public method | Clear | Clears the ITextView buffer
Public method | GetLine | Returns the Nth ITextView buffer line
Public method | Insert | Inserts a line of text at the Nth line in the ITextView buffer Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text
Public method | Remove | Removes the Nth ITextView buffer line
Public method | Replace | Replaces the Nth line in the ITextView buffer with a new text Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text
Public method | ScrollDown | Scrolls the scrollbar down 1 (wrapped line)
Public method | ScrollEnd | Scrolls the scrollbar to the end
Public method | ScrollHome | Scrolls the scrollbar to the start
Public method | ScrollPageDown | Scrolls the scrollbar 1 page down
Public method | ScrollPageUp | Scrolls the scrollbar 1 page up
Public method | ScrollTo | Scrolls the scrollbar to the Nth (wrapped) line
Public method | ScrollToUnreadLine | Scrolls the scrollbar to the unread line marker
Public method | ScrollUp | Scrolls the scrollbar up 1 (wrapped line)
Top
See Also

Reference

AdiIRCAPI Namespace


ITextView Properties

The ITextView type exposes the following members.

Properties
 | Name | Description
Public property | Lines | Returns the !TextView buffer lines
Public property | MaxBuffer | Returns the maxmimum buffer for this ITextView
Public property | MaxScrollbar | Returns the maxmimum number the scrollbar can scroll to (wrapped lines)
Public property | ScrollbarPos | Returns the current scrollbar position (wrapped lines)
Public property | UseTimestamp | Returns whether time stamps is enabled for this ITextView buffer
Top
See Also

Reference

ITextView Interface


ITextView.Lines Property

ITextViewLines Property

Returns the !TextView buffer lines

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection Lines { get; }
ReadOnly Property Lines As ICollection
    Get
property ICollection^ Lines {
    ICollection^ get ();
}
abstract Lines : ICollection with get

Property Value

Type: ICollection
See Also

Reference

ITextView Interface


ITextView.MaxBuffer Property

ITextViewMaxBuffer Property

Returns the maxmimum buffer for this ITextView

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxBuffer { get; set; }
Property MaxBuffer As Integer
    Get
    Set
property int MaxBuffer {
    int get ();
    void set (int value);
}
abstract MaxBuffer : int with get, set

Property Value

Type: Int32
See Also

Reference

ITextView Interface


ITextView.MaxScrollbar Property

ITextViewMaxScrollbar Property

Returns the maxmimum number the scrollbar can scroll to (wrapped lines)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxScrollbar { get; }
ReadOnly Property MaxScrollbar As Integer
    Get
property int MaxScrollbar {
    int get ();
}
abstract MaxScrollbar : int with get

Property Value

Type: Int32
See Also

Reference

ITextView Interface


ITextView.ScrollbarPos Property

ITextViewScrollbarPos Property

Returns the current scrollbar position (wrapped lines)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int ScrollbarPos { get; }
ReadOnly Property ScrollbarPos As Integer
    Get
property int ScrollbarPos {
    int get ();
}
abstract ScrollbarPos : int with get

Property Value

Type: Int32
See Also

Reference

ITextView Interface


ITextView.UseTimestamp Property

ITextViewUseTimestamp Property

Returns whether time stamps is enabled for this ITextView buffer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseTimestamp { get; }
ReadOnly Property UseTimestamp As Boolean
    Get
property bool UseTimestamp {
    bool get ();
}
abstract UseTimestamp : bool with get

Property Value

Type: Boolean
See Also

Reference

ITextView Interface


ITextView Methods

The ITextView type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a line of text to the ITextView buffer Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text
Public method | Clear | Clears the ITextView buffer
Public method | GetLine | Returns the Nth ITextView buffer line
Public method | Insert | Inserts a line of text at the Nth line in the ITextView buffer Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text
Public method | Remove | Removes the Nth ITextView buffer line
Public method | Replace | Replaces the Nth line in the ITextView buffer with a new text Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text
Public method | ScrollDown | Scrolls the scrollbar down 1 (wrapped line)
Public method | ScrollEnd | Scrolls the scrollbar to the end
Public method | ScrollHome | Scrolls the scrollbar to the start
Public method | ScrollPageDown | Scrolls the scrollbar 1 page down
Public method | ScrollPageUp | Scrolls the scrollbar 1 page up
Public method | ScrollTo | Scrolls the scrollbar to the Nth (wrapped) line
Public method | ScrollToUnreadLine | Scrolls the scrollbar to the unread line marker
Public method | ScrollUp | Scrolls the scrollbar up 1 (wrapped line)
Top
See Also

Reference

ITextView Interface


ITextView.Add Method

ITextViewAdd Method

Adds a line of text to the ITextView buffer Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    string Text,
    int lineColor,
    string rgbLineColor
)
Sub Add (
    Text As String,
    lineColor As Integer,
    rgbLineColor As String
)
void Add(
    String^ Text,
    int lineColor,
    String^ rgbLineColor
)
abstract Add :
        Text : string *
        lineColor : int *
        rgbLineColor : string -> unit

Parameters

Text
Type: SystemString

[Missing <param name="Text"/> documentation for "M:AdiIRCAPI.ITextView.Add(System.String,System.Int32,System.String)"]

lineColor
Type: SystemInt32

[Missing <param name="lineColor"/> documentation for "M:AdiIRCAPI.ITextView.Add(System.String,System.Int32,System.String)"]

rgbLineColor
Type: SystemString

[Missing <param name="rgbLineColor"/> documentation for "M:AdiIRCAPI.ITextView.Add(System.String,System.Int32,System.String)"]

See Also

Reference

ITextView Interface


ITextView.Clear Method

ITextViewClear Method

Clears the ITextView buffer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ITextView Interface


ITextView.GetLine Method

ITextViewGetLine Method

Returns the Nth ITextView buffer line

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetLine(
    int line
)
Function GetLine (
    line As Integer
) As String
String^ GetLine(
    int line
)
abstract GetLine :
        line : int -> string

Parameters

line
Type: SystemInt32

[Missing <param name="line"/> documentation for "M:AdiIRCAPI.ITextView.GetLine(System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:AdiIRCAPI.ITextView.GetLine(System.Int32)"]

See Also

Reference

ITextView Interface


ITextView.Insert Method

ITextViewInsert Method

Inserts a line of text at the Nth line in the ITextView buffer Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Insert(
    string text,
    int line,
    int lineColor,
    string rgbLineColor
)
Sub Insert (
    text As String,
    line As Integer,
    lineColor As Integer,
    rgbLineColor As String
)
void Insert(
    String^ text,
    int line,
    int lineColor,
    String^ rgbLineColor
)
abstract Insert :
        text : string *
        line : int *
        lineColor : int *
        rgbLineColor : string -> unit

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:AdiIRCAPI.ITextView.Insert(System.String,System.Int32,System.Int32,System.String)"]

line
Type: SystemInt32

[Missing <param name="line"/> documentation for "M:AdiIRCAPI.ITextView.Insert(System.String,System.Int32,System.Int32,System.String)"]

lineColor
Type: SystemInt32

[Missing <param name="lineColor"/> documentation for "M:AdiIRCAPI.ITextView.Insert(System.String,System.Int32,System.Int32,System.String)"]

rgbLineColor
Type: SystemString

[Missing <param name="rgbLineColor"/> documentation for "M:AdiIRCAPI.ITextView.Insert(System.String,System.Int32,System.Int32,System.String)"]

See Also

Reference

ITextView Interface


ITextView.Remove Method

ITextViewRemove Method

Removes the Nth ITextView buffer line

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Remove(
    int start,
    int end
)
Sub Remove (
    start As Integer,
    end As Integer
)
void Remove(
    int start,
    int end
)
abstract Remove :
        start : int *
        end : int -> unit

Parameters

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:AdiIRCAPI.ITextView.Remove(System.Int32,System.Int32)"]

end
Type: SystemInt32

[Missing <param name="end"/> documentation for "M:AdiIRCAPI.ITextView.Remove(System.Int32,System.Int32)"]

See Also

Reference

ITextView Interface


ITextView.Replace Method

ITextViewReplace Method

Replaces the Nth line in the ITextView buffer with a new text Adding lines manually requires all formatting to be done manually as well, format = timestamp + " " + ITools.NickColumChar + nick + ITools.NickColumChar + " " + text

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void Replace(
    string text,
    int line,
    int lineColor,
    string rgbLineColor
)
Sub Replace (
    text As String,
    line As Integer,
    lineColor As Integer,
    rgbLineColor As String
)
void Replace(
    String^ text,
    int line,
    int lineColor,
    String^ rgbLineColor
)
abstract Replace :
        text : string *
        line : int *
        lineColor : int *
        rgbLineColor : string -> unit

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:AdiIRCAPI.ITextView.Replace(System.String,System.Int32,System.Int32,System.String)"]

line
Type: SystemInt32

[Missing <param name="line"/> documentation for "M:AdiIRCAPI.ITextView.Replace(System.String,System.Int32,System.Int32,System.String)"]

lineColor
Type: SystemInt32

[Missing <param name="lineColor"/> documentation for "M:AdiIRCAPI.ITextView.Replace(System.String,System.Int32,System.Int32,System.String)"]

rgbLineColor
Type: SystemString

[Missing <param name="rgbLineColor"/> documentation for "M:AdiIRCAPI.ITextView.Replace(System.String,System.Int32,System.Int32,System.String)"]

See Also

Reference

ITextView Interface


ITextView.ScrollDown Method

ITextViewScrollDown Method

Scrolls the scrollbar down 1 (wrapped line)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollDown()
Sub ScrollDown
void ScrollDown()
abstract ScrollDown : unit -> unit
See Also

Reference

ITextView Interface


ITextView.ScrollEnd Method

ITextViewScrollEnd Method

Scrolls the scrollbar to the end

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollEnd()
Sub ScrollEnd
void ScrollEnd()
abstract ScrollEnd : unit -> unit
See Also

Reference

ITextView Interface


ITextView.ScrollHome Method

ITextViewScrollHome Method

Scrolls the scrollbar to the start

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollHome()
Sub ScrollHome
void ScrollHome()
abstract ScrollHome : unit -> unit
See Also

Reference

ITextView Interface


ITextView.ScrollPageDown Method

ITextViewScrollPageDown Method

Scrolls the scrollbar 1 page down

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollPageDown()
Sub ScrollPageDown
void ScrollPageDown()
abstract ScrollPageDown : unit -> unit
See Also

Reference

ITextView Interface


ITextView.ScrollPageUp Method

ITextViewScrollPageUp Method

Scrolls the scrollbar 1 page up

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollPageUp()
Sub ScrollPageUp
void ScrollPageUp()
abstract ScrollPageUp : unit -> unit
See Also

Reference

ITextView Interface


ITextView.ScrollTo Method

ITextViewScrollTo Method

Scrolls the scrollbar to the Nth (wrapped) line

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollTo(
    int line
)
Sub ScrollTo (
    line As Integer
)
void ScrollTo(
    int line
)
abstract ScrollTo :
        line : int -> unit

Parameters

line
Type: SystemInt32

[Missing <param name="line"/> documentation for "M:AdiIRCAPI.ITextView.ScrollTo(System.Int32)"]

See Also

Reference

ITextView Interface


ITextView.ScrollToUnreadLine Method

ITextViewScrollToUnreadLine Method

Scrolls the scrollbar to the unread line marker

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollToUnreadLine()
Sub ScrollToUnreadLine
void ScrollToUnreadLine()
abstract ScrollToUnreadLine : unit -> unit
See Also

Reference

ITextView Interface


ITextView.ScrollUp Method

ITextViewScrollUp Method

Scrolls the scrollbar up 1 (wrapped line)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollUp()
Sub ScrollUp
void ScrollUp()
abstract ScrollUp : unit -> unit
See Also

Reference

ITextView Interface


ITools Interface

Various tools

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITools
Public Interface ITools
public interface class ITools
type ITools =  interface end

The ITools type exposes the following members.

Properties
 | Name | Description
Public property | ActionChar | Gets the action character
Public property | BoldChar | Gets the bold character
Public property | ColorChar | Gets the color character
Public property | LinkChar | Gets the link character used to determine if the text in the ITextView buffer is a link
Public property | NickColumnChar | Gets the nick column character used to determine where in the ITextView buffer the nick coulmn should be
Public property | PS | Gets path sperator / or \ , for future use
Public property | UnderLineChar | Gets the underline character
Top
Methods
 | Name | Description
Public method | Boldify | Makes the text bold if Boldify is enabled
Public method | DateToUnixTime | Converts DateTime to unix timestamp
Public method | Debug | Use this to write to debug.txt in the main folder, returns true if the debug was written
Public method | IsNumeric | Checks if a string is numeric
Public method | ParseSysinfo | Returns system information based on Syntax, see system variables for more information
Public method | ParseTime | Converts string to DateTime, see Time variables for possible syntax
Public method | SplitString | Splits a string by a string
Public method | StripBold | Returns a string with bold stripped out
Public method | StripColors | Returns a string with colors stripped out
Public method | StripItalic | Returns a string with italic stripped out
Public method | StripUnderline | Returns a string with underline stripped out
Public method | ToolWindow | Open ups a tool window
Public method | UnixTimeToDate | Converts unix timestamp to a DateTime
Top
See Also

Reference

AdiIRCAPI Namespace


ITools Properties

The ITools type exposes the following members.

Properties
 | Name | Description
Public property | ActionChar | Gets the action character
Public property | BoldChar | Gets the bold character
Public property | ColorChar | Gets the color character
Public property | LinkChar | Gets the link character used to determine if the text in the ITextView buffer is a link
Public property | NickColumnChar | Gets the nick column character used to determine where in the ITextView buffer the nick coulmn should be
Public property | PS | Gets path sperator / or \ , for future use
Public property | UnderLineChar | Gets the underline character
Top
See Also

Reference

ITools Interface


ITools.ActionChar Property

IToolsActionChar Property

Gets the action character

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
char ActionChar { get; }
ReadOnly Property ActionChar As Char
    Get
property wchar_t ActionChar {
    wchar_t get ();
}
abstract ActionChar : char with get

Property Value

Type: Char
See Also

Reference

ITools Interface


ITools.BoldChar Property

IToolsBoldChar Property

Gets the bold character

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
char BoldChar { get; }
ReadOnly Property BoldChar As Char
    Get
property wchar_t BoldChar {
    wchar_t get ();
}
abstract BoldChar : char with get

Property Value

Type: Char
See Also

Reference

ITools Interface


ITools.ColorChar Property

IToolsColorChar Property

Gets the color character

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
char ColorChar { get; }
ReadOnly Property ColorChar As Char
    Get
property wchar_t ColorChar {
    wchar_t get ();
}
abstract ColorChar : char with get

Property Value

Type: Char
See Also

Reference

ITools Interface


ITools.LinkChar Property

IToolsLinkChar Property

Gets the link character used to determine if the text in the ITextView buffer is a link

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
char LinkChar { get; }
ReadOnly Property LinkChar As Char
    Get
property wchar_t LinkChar {
    wchar_t get ();
}
abstract LinkChar : char with get

Property Value

Type: Char
See Also

Reference

ITools Interface


ITools.NickColumnChar Property

IToolsNickColumnChar Property

Gets the nick column character used to determine where in the ITextView buffer the nick coulmn should be

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
char NickColumnChar { get; }
ReadOnly Property NickColumnChar As Char
    Get
property wchar_t NickColumnChar {
    wchar_t get ();
}
abstract NickColumnChar : char with get

Property Value

Type: Char
See Also

Reference

ITools Interface


ITools.PS Property

IToolsPS Property

Gets path sperator / or \ , for future use

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string PS { get; }
ReadOnly Property PS As String
    Get
property String^ PS {
    String^ get ();
}
abstract PS : string with get

Property Value

Type: String
See Also

Reference

ITools Interface


ITools.UnderLineChar Property

IToolsUnderLineChar Property

Gets the underline character

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
char UnderLineChar { get; }
ReadOnly Property UnderLineChar As Char
    Get
property wchar_t UnderLineChar {
    wchar_t get ();
}
abstract UnderLineChar : char with get

Property Value

Type: Char
See Also

Reference

ITools Interface


ITools Methods

The ITools type exposes the following members.

Methods
 | Name | Description
Public method | Boldify | Makes the text bold if Boldify is enabled
Public method | DateToUnixTime | Converts DateTime to unix timestamp
Public method | Debug | Use this to write to debug.txt in the main folder, returns true if the debug was written
Public method | IsNumeric | Checks if a string is numeric
Public method | ParseSysinfo | Returns system information based on Syntax, see system variables for more information
Public method | ParseTime | Converts string to DateTime, see Time variables for possible syntax
Public method | SplitString | Splits a string by a string
Public method | StripBold | Returns a string with bold stripped out
Public method | StripColors | Returns a string with colors stripped out
Public method | StripItalic | Returns a string with italic stripped out
Public method | StripUnderline | Returns a string with underline stripped out
Public method | ToolWindow | Open ups a tool window
Public method | UnixTimeToDate | Converts unix timestamp to a DateTime
Top
See Also

Reference

ITools Interface


ITools.Boldify Method

IToolsBoldify Method

Makes the text bold if Boldify is enabled

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Boldify(
    string text
)
Function Boldify (
    text As String
) As String
String^ Boldify(
    String^ text
)
abstract Boldify :
        text : string -> string

Parameters

text
Type: SystemString
Text to boldify

Return Value

Type: String
Boldified text
See Also

Reference

ITools Interface


ITools.DateToUnixTime Method

IToolsDateToUnixTime Method

Converts DateTime to unix timestamp

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
long DateToUnixTime(
    DateTime Time
)
Function DateToUnixTime (
    Time As DateTime
) As Long
long long DateToUnixTime(
    DateTime Time
)
abstract DateToUnixTime :
        Time : DateTime -> int64

Parameters

Time
Type: SystemDateTime
DateTime

Return Value

Type: Int64
A unix timestamp value
See Also

Reference

ITools Interface


ITools.Debug Method

IToolsDebug Method

Use this to write to debug.txt in the main folder, returns true if the debug was written

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Debug(
    string Str
)
Function Debug (
    Str As String
) As Boolean
bool Debug(
    String^ Str
)
abstract Debug :
        Str : string -> bool

Parameters

Str
Type: SystemString
String

Return Value

Type: Boolean
True/False depending if the write was successful
See Also

Reference

ITools Interface


ITools.IsNumeric Method

IToolsIsNumeric Method

Checks if a string is numeric

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsNumeric(
    string Str
)
Function IsNumeric (
    Str As String
) As Boolean
bool IsNumeric(
    String^ Str
)
abstract IsNumeric :
        Str : string -> bool

Parameters

Str
Type: SystemString
String

Return Value

Type: Boolean
True/False whether the string is a number
See Also

Reference

ITools Interface


ITools.ParseSysinfo Method

IToolsParseSysinfo Method

Returns system information based on Syntax, see system variables for more information

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ParseSysinfo(
    string Str,
    string Args
)
Function ParseSysinfo (
    Str As String,
    Args As String
) As String
String^ ParseSysinfo(
    String^ Str,
    String^ Args
)
abstract ParseSysinfo :
        Str : string *
        Args : string -> string

Parameters

Str
Type: SystemString
String
Args
Type: SystemString
String

Return Value

Type: String
A oarsed string
See Also

Reference

ITools Interface


ITools.ParseTime Method

IToolsParseTime Method

Converts string to DateTime, see Time variables for possible syntax

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string ParseTime(
    string Syntax,
    DateTime Time
)
Function ParseTime (
    Syntax As String,
    Time As DateTime
) As String
String^ ParseTime(
    String^ Syntax,
    DateTime Time
)
abstract ParseTime :
        Syntax : string *
        Time : DateTime -> string

Parameters

Syntax
Type: SystemString
String
Time
Type: SystemDateTime
DateTime

Return Value

Type: String
A parsed string
See Also

Reference

ITools Interface


ITools.SplitString Method

IToolsSplitString Method

Splits a string by a string

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] SplitString(
    string Str,
    string SplitBy
)
Function SplitString (
    Str As String,
    SplitBy As String
) As String()
array<String^>^ SplitString(
    String^ Str,
    String^ SplitBy
)
abstract SplitString :
        Str : string *
        SplitBy : string -> string[]

Parameters

Str
Type: SystemString
String
SplitBy
Type: SystemString
String

Return Value

Type: String
A list of strings
See Also

Reference

ITools Interface


ITools.StripBold Method

IToolsStripBold Method

Returns a string with bold stripped out

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string StripBold(
    string Str
)
Function StripBold (
    Str As String
) As String
String^ StripBold(
    String^ Str
)
abstract StripBold :
        Str : string -> string

Parameters

Str
Type: SystemString
String

Return Value

Type: String
A stripped string
See Also

Reference

ITools Interface


ITools.StripColors Method

IToolsStripColors Method

Returns a string with colors stripped out

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string StripColors(
    string Str
)
Function StripColors (
    Str As String
) As String
String^ StripColors(
    String^ Str
)
abstract StripColors :
        Str : string -> string

Parameters

Str
Type: SystemString
String

Return Value

Type: String
A stripped string
See Also

Reference

ITools Interface


ITools.StripItalic Method

IToolsStripItalic Method

Returns a string with italic stripped out

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string StripItalic(
    string Str
)
Function StripItalic (
    Str As String
) As String
String^ StripItalic(
    String^ Str
)
abstract StripItalic :
        Str : string -> string

Parameters

Str
Type: SystemString
String

Return Value

Type: String
A stripped string
See Also

Reference

ITools Interface


ITools.StripUnderline Method

IToolsStripUnderline Method

Returns a string with underline stripped out

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string StripUnderline(
    string Str
)
Function StripUnderline (
    Str As String
) As String
String^ StripUnderline(
    String^ Str
)
abstract StripUnderline :
        Str : string -> string

Parameters

Str
Type: SystemString
String

Return Value

Type: String
A stripped string
See Also

Reference

ITools Interface


ITools.ToolWindow Method

IToolsToolWindow Method

Open ups a tool window

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToolWindow(
    int Height,
    int Width,
    string Title,
    string Text
)
Sub ToolWindow (
    Height As Integer,
    Width As Integer,
    Title As String,
    Text As String
)
void ToolWindow(
    int Height,
    int Width,
    String^ Title,
    String^ Text
)
abstract ToolWindow :
        Height : int *
        Width : int *
        Title : string *
        Text : string -> unit

Parameters

Height
Type: SystemInt32
int
Width
Type: SystemInt32
int
Title
Type: SystemString
String
Text
Type: SystemString
String
See Also

Reference

ITools Interface


ITools.UnixTimeToDate Method

IToolsUnixTimeToDate Method

Converts unix timestamp to a DateTime

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UnixTimeToDate(
    double Time
)
Function UnixTimeToDate (
    Time As Double
) As DateTime
DateTime UnixTimeToDate(
    double Time
)
abstract UnixTimeToDate :
        Time : float -> DateTime

Parameters

Time
Type: SystemDouble
Double

Return Value

Type: DateTime
A Datetime value
See Also

Reference

ITools Interface


IUser Interface

Represents a user

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUser
Public Interface IUser
public interface class IUser
type IUser =  interface end

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Editbox | Returns the IEditbox for the IUser/private window (can be null)
Public property | GetChannels | Retrive all channels this IUser is in
Public property | HasSpoken | /// Returns whether the user has spoken since joining the IChannel
Public property | HasVoice | Get whether user has IChannel voice (+)
Public property | Host | Get user hostname
Public property | Ident | Get user ident
Public property | IdleTime | /// Returns the time user last sent a message to this IChannel (UTC time)
Public property | IsAway | Get whether user is away
Public property | IsHalfOperator | Get whether user is IChannel half operator (%)
Public property | IsOperator | Get whether user is IChannel operator (@)
Public property | IsOwner | Get whether user is IChannel owner (&)
Public property | IsPOperator | Get whether user is IChannel special operator (!)
Public property | Joined | /// Returns the time the user joined the IChannel (UTC time)
Public property | Nick | Get user nick
Public property | NickColor | /// Returns the nick color to use for the nick on this IChannel (UTC time)
Public property | RealName | Get user realname
Public property | RgbNickColor | /// Returns the rgb nick color to use for the nick on this IChannel (UTC time)
Public property | Window | returns the IWindow associated with this IUser
Top
See Also

Reference

AdiIRCAPI Namespace


IUser Properties

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Editbox | Returns the IEditbox for the IUser/private window (can be null)
Public property | GetChannels | Retrive all channels this IUser is in
Public property | HasSpoken | /// Returns whether the user has spoken since joining the IChannel
Public property | HasVoice | Get whether user has IChannel voice (+)
Public property | Host | Get user hostname
Public property | Ident | Get user ident
Public property | IdleTime | /// Returns the time user last sent a message to this IChannel (UTC time)
Public property | IsAway | Get whether user is away
Public property | IsHalfOperator | Get whether user is IChannel half operator (%)
Public property | IsOperator | Get whether user is IChannel operator (@)
Public property | IsOwner | Get whether user is IChannel owner (&)
Public property | IsPOperator | Get whether user is IChannel special operator (!)
Public property | Joined | /// Returns the time the user joined the IChannel (UTC time)
Public property | Nick | Get user nick
Public property | NickColor | /// Returns the nick color to use for the nick on this IChannel (UTC time)
Public property | RealName | Get user realname
Public property | RgbNickColor | /// Returns the rgb nick color to use for the nick on this IChannel (UTC time)
Public property | Window | returns the IWindow associated with this IUser
Top
See Also

Reference

IUser Interface


IUser.Editbox Property

IUserEditbox Property

Returns the IEditbox for the IUser/private window (can be null)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditbox Editbox { get; }
ReadOnly Property Editbox As IEditbox
    Get
property IEditbox^ Editbox {
    IEditbox^ get ();
}
abstract Editbox : IEditbox with get

Property Value

Type: IEditbox
See Also

Reference

IUser Interface


IUser.GetChannels Property

IUserGetChannels Property

Retrive all channels this IUser is in

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection GetChannels { get; }
ReadOnly Property GetChannels As ICollection
    Get
property ICollection^ GetChannels {
    ICollection^ get ();
}
abstract GetChannels : ICollection with get

Property Value

Type: ICollection
See Also

Reference

IUser Interface


IUser.HasSpoken Property

IUserHasSpoken Property

/// Returns whether the user has spoken since joining the IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasSpoken { get; }
ReadOnly Property HasSpoken As Boolean
    Get
property bool HasSpoken {
    bool get ();
}
abstract HasSpoken : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.HasVoice Property

IUserHasVoice Property

Get whether user has IChannel voice (+)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasVoice { get; }
ReadOnly Property HasVoice As Boolean
    Get
property bool HasVoice {
    bool get ();
}
abstract HasVoice : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.Host Property

IUserHost Property

Get user hostname

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Host { get; }
ReadOnly Property Host As String
    Get
property String^ Host {
    String^ get ();
}
abstract Host : string with get

Property Value

Type: String
See Also

Reference

IUser Interface


IUser.Ident Property

IUserIdent Property

Get user ident

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Ident { get; }
ReadOnly Property Ident As String
    Get
property String^ Ident {
    String^ get ();
}
abstract Ident : string with get

Property Value

Type: String
See Also

Reference

IUser Interface


IUser.IdleTime Property

IUserIdleTime Property

/// Returns the time user last sent a message to this IChannel (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime IdleTime { get; }
ReadOnly Property IdleTime As DateTime
    Get
property DateTime IdleTime {
    DateTime get ();
}
abstract IdleTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IUser Interface


IUser.IsAway Property

IUserIsAway Property

Get whether user is away

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsAway { get; }
ReadOnly Property IsAway As Boolean
    Get
property bool IsAway {
    bool get ();
}
abstract IsAway : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.IsHalfOperator Property

IUserIsHalfOperator Property

Get whether user is IChannel half operator (%)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsHalfOperator { get; }
ReadOnly Property IsHalfOperator As Boolean
    Get
property bool IsHalfOperator {
    bool get ();
}
abstract IsHalfOperator : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.IsOperator Property

IUserIsOperator Property

Get whether user is IChannel operator (@)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsOperator { get; }
ReadOnly Property IsOperator As Boolean
    Get
property bool IsOperator {
    bool get ();
}
abstract IsOperator : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.IsOwner Property

IUserIsOwner Property

Get whether user is IChannel owner (&)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsOwner { get; }
ReadOnly Property IsOwner As Boolean
    Get
property bool IsOwner {
    bool get ();
}
abstract IsOwner : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.IsPOperator Property

IUserIsPOperator Property

Get whether user is IChannel special operator (!)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPOperator { get; }
ReadOnly Property IsPOperator As Boolean
    Get
property bool IsPOperator {
    bool get ();
}
abstract IsPOperator : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface


IUser.Joined Property

IUserJoined Property

/// Returns the time the user joined the IChannel (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime Joined { get; }
ReadOnly Property Joined As DateTime
    Get
property DateTime Joined {
    DateTime get ();
}
abstract Joined : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IUser Interface


IUser.Nick Property

IUserNick Property

Get user nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Nick { get; }
ReadOnly Property Nick As String
    Get
property String^ Nick {
    String^ get ();
}
abstract Nick : string with get

Property Value

Type: String
See Also

Reference

IUser Interface


IUser.NickColor Property

IUserNickColor Property

/// Returns the nick color to use for the nick on this IChannel (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int NickColor { get; }
ReadOnly Property NickColor As Integer
    Get
property int NickColor {
    int get ();
}
abstract NickColor : int with get

Property Value

Type: Int32
See Also

Reference

IUser Interface


IUser.RealName Property

IUserRealName Property

Get user realname

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string RealName { get; }
ReadOnly Property RealName As String
    Get
property String^ RealName {
    String^ get ();
}
abstract RealName : string with get

Property Value

Type: String
See Also

Reference

IUser Interface


IUser.RgbNickColor Property

IUserRgbNickColor Property

/// Returns the rgb nick color to use for the nick on this IChannel (UTC time)

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string RgbNickColor { get; }
ReadOnly Property RgbNickColor As String
    Get
property String^ RgbNickColor {
    String^ get ();
}
abstract RgbNickColor : string with get

Property Value

Type: String
See Also

Reference

IUser Interface


IUser.Window Property

IUserWindow Property

returns the IWindow associated with this IUser

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IWindow Window { get; }
ReadOnly Property Window As IWindow
    Get
property IWindow^ Window {
    IWindow^ get ();
}
abstract Window : IWindow with get

Property Value

Type: IWindow
See Also

Reference

IUser Interface


IWindow Interface

Represents a form window

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWindow
Public Interface IWindow
public interface class IWindow
type IWindow =  interface end

The IWindow type exposes the following members.

Properties
 | Name | Description
Public property | Channel | Returns the IChannel associated with this IWindow
Public property | CustomWindow | Returns the ICustomWindow associated with this IWindow
Public property | Editbox | Returns the IEditbox associated with this IWindow
Public property | IsMdiChild | Returns whether the IWindow is a MDI child
Public property | LogFile | Returns the name of the log file associated with this IWindow
Public property | Name | Return the name of the IWindow
Public property | NiceName | Return the window name of the IWindow
Public property | Server | Returns the IServer associated with this IWindow
Public property | Text | Returns the IWindow title text
Public property | TextView | Returns the ITextView associated with this IWindow
Public property | UnreadMessages | Returns number of unread messages in this IWindow
Public property | User | Returns the IUser associated with this IWindow
Public property | Visible | Returns whether the IWindow is visible
Public property | WindowId | Returns the window id of this IWindow
Public property | WindowState | Returns the IWindow window state
Public property | WindowType | Returns the WindowType of this IWindow
Public property | WindowTypeNum | Returns the WindowType of this IWindow in a numeric form
Top
See Also

Reference

AdiIRCAPI Namespace


IWindow Properties

The IWindow type exposes the following members.

Properties
 | Name | Description
Public property | Channel | Returns the IChannel associated with this IWindow
Public property | CustomWindow | Returns the ICustomWindow associated with this IWindow
Public property | Editbox | Returns the IEditbox associated with this IWindow
Public property | IsMdiChild | Returns whether the IWindow is a MDI child
Public property | LogFile | Returns the name of the log file associated with this IWindow
Public property | Name | Return the name of the IWindow
Public property | NiceName | Return the window name of the IWindow
Public property | Server | Returns the IServer associated with this IWindow
Public property | Text | Returns the IWindow title text
Public property | TextView | Returns the ITextView associated with this IWindow
Public property | UnreadMessages | Returns number of unread messages in this IWindow
Public property | User | Returns the IUser associated with this IWindow
Public property | Visible | Returns whether the IWindow is visible
Public property | WindowId | Returns the window id of this IWindow
Public property | WindowState | Returns the IWindow window state
Public property | WindowType | Returns the WindowType of this IWindow
Public property | WindowTypeNum | Returns the WindowType of this IWindow in a numeric form
Top
See Also

Reference

IWindow Interface


IWindow.Channel Property

IWindowChannel Property

Returns the IChannel associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IChannel Channel { get; }
ReadOnly Property Channel As IChannel
    Get
property IChannel^ Channel {
    IChannel^ get ();
}
abstract Channel : IChannel with get

Property Value

Type: IChannel
See Also

Reference

IWindow Interface


IWindow.CustomWindow Property

IWindowCustomWindow Property

Returns the ICustomWindow associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ICustomWindow CustomWindow { get; }
ReadOnly Property CustomWindow As ICustomWindow
    Get
property ICustomWindow^ CustomWindow {
    ICustomWindow^ get ();
}
abstract CustomWindow : ICustomWindow with get

Property Value

Type: ICustomWindow
See Also

Reference

IWindow Interface


IWindow.Editbox Property

IWindowEditbox Property

Returns the IEditbox associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditbox Editbox { get; }
ReadOnly Property Editbox As IEditbox
    Get
property IEditbox^ Editbox {
    IEditbox^ get ();
}
abstract Editbox : IEditbox with get

Property Value

Type: IEditbox
See Also

Reference

IWindow Interface


IWindow.IsMdiChild Property

IWindowIsMdiChild Property

Returns whether the IWindow is a MDI child

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMdiChild { get; }
ReadOnly Property IsMdiChild As Boolean
    Get
property bool IsMdiChild {
    bool get ();
}
abstract IsMdiChild : bool with get

Property Value

Type: Boolean
See Also

Reference

IWindow Interface


IWindow.LogFile Property

IWindowLogFile Property

Returns the name of the log file associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string LogFile { get; }
ReadOnly Property LogFile As String
    Get
property String^ LogFile {
    String^ get ();
}
abstract LogFile : string with get

Property Value

Type: String
See Also

Reference

IWindow Interface


IWindow.Name Property

IWindowName Property

Return the name of the IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IWindow Interface


IWindow.NiceName Property

IWindowNiceName Property

Return the window name of the IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string NiceName { get; }
ReadOnly Property NiceName As String
    Get
property String^ NiceName {
    String^ get ();
}
abstract NiceName : string with get

Property Value

Type: String
See Also

Reference

IWindow Interface


IWindow.Server Property

IWindowServer Property

Returns the IServer associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IServer Server { get; }
ReadOnly Property Server As IServer
    Get
property IServer^ Server {
    IServer^ get ();
}
abstract Server : IServer with get

Property Value

Type: IServer
See Also

Reference

IWindow Interface


IWindow.Text Property

IWindowText Property

Returns the IWindow title text

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; }
ReadOnly Property Text As String
    Get
property String^ Text {
    String^ get ();
}
abstract Text : string with get

Property Value

Type: String
See Also

Reference

IWindow Interface


IWindow.TextView Property

IWindowTextView Property

Returns the ITextView associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextView TextView { get; }
ReadOnly Property TextView As ITextView
    Get
property ITextView^ TextView {
    ITextView^ get ();
}
abstract TextView : ITextView with get

Property Value

Type: ITextView
See Also

Reference

IWindow Interface


IWindow.UnreadMessages Property

IWindowUnreadMessages Property

Returns number of unread messages in this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int UnreadMessages { get; }
ReadOnly Property UnreadMessages As Integer
    Get
property int UnreadMessages {
    int get ();
}
abstract UnreadMessages : int with get

Property Value

Type: Int32
See Also

Reference

IWindow Interface


IWindow.User Property

IWindowUser Property

Returns the IUser associated with this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
IUser User { get; }
ReadOnly Property User As IUser
    Get
property IUser^ User {
    IUser^ get ();
}
abstract User : IUser with get

Property Value

Type: IUser
See Also

Reference

IWindow Interface


IWindow.Visible Property

IWindowVisible Property

Returns whether the IWindow is visible

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWindow Interface


IWindow.WindowId Property

IWindowWindowId Property

Returns the window id of this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int WindowId { get; }
ReadOnly Property WindowId As Integer
    Get
property int WindowId {
    int get ();
}
abstract WindowId : int with get

Property Value

Type: Int32
See Also

Reference

IWindow Interface


IWindow.WindowState Property

IWindowWindowState Property

Returns the IWindow window state

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
FormWindowState WindowState { get; set; }
Property WindowState As FormWindowState
    Get
    Set
property FormWindowState WindowState {
    FormWindowState get ();
    void set (FormWindowState value);
}
abstract WindowState : FormWindowState with get, set

Property Value

Type: FormWindowState
See Also

Reference

IWindow Interface


IWindow.WindowType Property

IWindowWindowType Property

Returns the WindowType of this IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
WindowType WindowType { get; }
ReadOnly Property WindowType As WindowType
    Get
property WindowType WindowType {
    WindowType get ();
}
abstract WindowType : WindowType with get

Property Value

Type: WindowType
See Also

Reference

IWindow Interface


IWindow.WindowTypeNum Property

IWindowWindowTypeNum Property

Returns the WindowType of this IWindow in a numeric form

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
int WindowTypeNum { get; }
ReadOnly Property WindowTypeNum As Integer
    Get
property int WindowTypeNum {
    int get ();
}
abstract WindowTypeNum : int with get

Property Value

Type: Int32
See Also

Reference

IWindow Interface


Join Delegate

Delegate gets called when a IUser joines a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Join(
    IServer Server,
    IChannel Channel,
    IUser User,
    out EatData Return
)
Public Delegate Sub Join (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Join(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    [OutAttribute] EatData% Return
)
type Join =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Kick Delegate

Delegate gets called when a IUser is kicked from IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Kick(
    IServer Server,
    IChannel Channel,
    IUser User,
    IUser ByUser,
    string KickReason,
    out EatData Return
)
Public Delegate Sub Kick (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    ByUser As IUser,
    KickReason As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Kick(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    IUser^ ByUser,
    String^ KickReason,
    [OutAttribute] EatData% Return
)
type Kick =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        ByUser : IUser *
        KickReason : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
ByUser
Type: AdiIRCAPIIUser
IUser
KickReason
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Menu Delegate

Delegate gets called when a menu is opened

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Menu(
    IServer Server,
    Object Window,
    MenuType MenuType,
    string Text,
    ToolStripItemCollection MenuItems
)
Public Delegate Sub Menu (
    Server As IServer,
    Window As Object,
    MenuType As MenuType,
    Text As String,
    MenuItems As ToolStripItemCollection
)
public delegate void Menu(
    IServer^ Server,
    Object^ Window,
    MenuType MenuType,
    String^ Text,
    ToolStripItemCollection^ MenuItems
)
type Menu =
    delegate of
        Server : IServer *
        Window : Object *
        MenuType : MenuType *
        Text : string *
        MenuItems : ToolStripItemCollection -> unit

Parameters

Server
Type: AdiIRCAPIIServer
Window
Type: SystemObject
Object
MenuType
Type: AdiIRCAPIMenuType
MenuType
Text
Type: SystemString
String
MenuItems
Type: System.Windows.FormsToolStripItemCollection
ToolStripItemCollection
See Also

Reference

AdiIRCAPI Namespace


MenuType Enumeration

Used to determine the menu type during a OnMenu event

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MenuType
Public Enumeration MenuType
public enum class MenuType
type MenuType
Members
Member name | Value | Description
None | 0 | Indicates the OnMenu event has no type
Server | 1 | Indicates the OnMenu event is for a Server window
Channel | 2 | Indicates the OnMenu event is for a Channel window
Private | 3 | Indicates the OnMenu event is for a Private window
Custom | 4 | Indicates the OnMenu event is for a Custom window
Nicklist | 5 | Indicates the OnMenu event is for a Nicklist nick
Menubar | 6 | Indicates the OnMenu event is for the Menubar
ChannelLink | 7 | Indicates the OnMenu event is for a Channel link
Link | 8 | Indicates the OnMenu event is for a link
See Also

Reference

AdiIRCAPI Namespace


Message Delegate

Delegate gets called when a IChannel revices a message

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Message(
    IServer Server,
    IChannel Channel,
    IUser User,
    string Message,
    out EatData Return
)
Public Delegate Sub Message (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    Message As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Message(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    String^ Message,
    [OutAttribute] EatData% Return
)
type Message =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        Message : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
Message
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Mode Delegate

Delegate gets called when a IChannel revices a mode

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Mode(
    IServer Server,
    IChannel Channel,
    IUser User,
    string Mode,
    out EatData Return
)
Public Delegate Sub Mode (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    Mode As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Mode(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    String^ Mode,
    [OutAttribute] EatData% Return
)
type Mode =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        Mode : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
Mode
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Nick Delegate

Delegate gets called when a IUser change nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Nick(
    IServer Server,
    IUser User,
    string NewNick,
    out EatData Return
)
Public Delegate Sub Nick (
    Server As IServer,
    User As IUser,
    NewNick As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Nick(
    IServer^ Server,
    IUser^ User,
    String^ NewNick,
    [OutAttribute] EatData% Return
)
type Nick =
    delegate of
        Server : IServer *
        User : IUser *
        NewNick : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
User
Type: AdiIRCAPIIUser
IUser
NewNick
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


OptionsChanged Delegate

Delegate gets called when the user changes a options and the config file is reloaded.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void OptionsChanged()
Public Delegate Sub OptionsChanged
public delegate void OptionsChanged()
type OptionsChanged =
    delegate of unit -> unit
See Also

Reference

AdiIRCAPI Namespace


Part Delegate

Delegate gets called when a IUser parts a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Part(
    IServer Server,
    IChannel Channel,
    IUser User,
    string PartMessage,
    out EatData Return
)
Public Delegate Sub Part (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    PartMessage As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Part(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    String^ PartMessage,
    [OutAttribute] EatData% Return
)
type Part =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        PartMessage : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
PartMessage
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


PrivateMessage Delegate

Delegate gets called when your IUser recives a private message

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void PrivateMessage(
    IServer Server,
    IUser User,
    string Message,
    out EatData Return
)
Public Delegate Sub PrivateMessage (
    Server As IServer,
    User As IUser,
    Message As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void PrivateMessage(
    IServer^ Server,
    IUser^ User,
    String^ Message,
    [OutAttribute] EatData% Return
)
type PrivateMessage =
    delegate of
        Server : IServer *
        User : IUser *
        Message : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
User
Type: AdiIRCAPIIUser
IUser
Message
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Quit Delegate

Delegate gets called when a IUser quits the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Quit(
    IServer Server,
    IUser User,
    string Data,
    out EatData Return
)
Public Delegate Sub Quit (
    Server As IServer,
    User As IUser,
    Data As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Quit(
    IServer^ Server,
    IUser^ User,
    String^ Data,
    [OutAttribute] EatData% Return
)
type Quit =
    delegate of
        Server : IServer *
        User : IUser *
        Data : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
User
Type: AdiIRCAPIIUser
IUser
Data
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
Return
See Also

Reference

AdiIRCAPI Namespace


RawData Delegate

Delegate gets called when any raw data is recieved to the IServer. You can modify the byte array args, AdiIRC will then parse this array with the proper encoding. If the array is set to null or zero bytes, the raw message is ignored by AdiIRC.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void RawData(
    Object sender,
    RawDataArgs e
)
Public Delegate Sub RawData (
    sender As Object,
    e As RawDataArgs
)
public delegate void RawData(
    Object^ sender,
    RawDataArgs^ e
)
type RawData =
    delegate of
        sender : Object *
        e : RawDataArgs -> unit

Parameters

sender
Type: SystemObject
object
e
Type: AdiIRCAPIRawDataArgs
RawDataArgs
See Also

Reference

AdiIRCAPI Namespace


RawDataArgs Class

RawDataArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
AdiIRCAPIRawDataArgs

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RawDataArgs : EventArgs
Public Class RawDataArgs
    Inherits EventArgs
public ref class RawDataArgs : public EventArgs
type RawDataArgs =
    class
        inherit EventArgs
    end

The RawDataArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RawDataArgs | RawDataArgs
Top
Properties
 | Name | Description
Public property | Bytes | The raw bytes of this event.
Public property | Server | The IServer of this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdiIRCAPI Namespace


RawDataArgs Constructor

RawDataArgs

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public RawDataArgs(
    IServer server,
    byte[] bytes
)
Public Sub New (
    server As IServer,
    bytes As Byte()
)
public:
RawDataArgs(
    IServer^ server,
    array<unsigned char>^ bytes
)
new :
        server : IServer *
        bytes : byte[] -> RawDataArgs

Parameters

server
Type: AdiIRCAPIIServer

[Missing <param name="server"/> documentation for "M:AdiIRCAPI.RawDataArgs.#ctor(AdiIRCAPI.IServer,System.Byte[])"]

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:AdiIRCAPI.RawDataArgs.#ctor(AdiIRCAPI.IServer,System.Byte[])"]

See Also

Reference

RawDataArgs Class


RawDataArgs Properties

The RawDataArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | The raw bytes of this event.
Public property | Server | The IServer of this event.
Top
See Also

Reference

RawDataArgs Class


RawDataArgs.Bytes Property

RawDataArgsBytes Property

The raw bytes of this event.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes { get; set; }
Public Property Bytes As Byte()
    Get
    Set
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Bytes : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

RawDataArgs Class


RawDataArgs.Server Property

RawDataArgsServer Property

The IServer of this event.

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public IServer Server { get; set; }
Public Property Server As IServer
    Get
    Set
public:
property IServer^ Server {
    IServer^ get ();
    void set (IServer^ value);
}
member Server : IServer with get, set

Property Value

Type: IServer
See Also

Reference

RawDataArgs Class


RawDataArgs Methods

The RawDataArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RawDataArgs Class


Registered Delegate

Delegate gets called when a IServer is registered

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Registered(
    IServer Server
)
Public Delegate Sub Registered (
    Server As IServer
)
public delegate void Registered(
    IServer^ Server
)
type Registered =
    delegate of
        Server : IServer -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
See Also

Reference

AdiIRCAPI Namespace


SendData Delegate

Delegate gets called when user sends data to the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void SendData(
    IServer Server,
    string Data,
    out EatData Return
)
Public Delegate Sub SendData (
    Server As IServer,
    Data As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void SendData(
    IServer^ Server,
    String^ Data,
    [OutAttribute] EatData% Return
)
type SendData =
    delegate of
        Server : IServer *
        Data : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Data
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


ServerNotice Delegate

Delegate gets called when a IServer recives a notice

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ServerNotice(
    IServer Server,
    string Notice,
    out EatData Return
)
Public Delegate Sub ServerNotice (
    Server As IServer,
    Notice As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void ServerNotice(
    IServer^ Server,
    String^ Notice,
    [OutAttribute] EatData% Return
)
type ServerNotice =
    delegate of
        Server : IServer *
        Notice : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Notice
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


Topic Delegate

Delegate gets called when a IUser changes topic in IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void Topic(
    IServer Server,
    IChannel Channel,
    IUser User,
    string NewTopic,
    out EatData Return
)
Public Delegate Sub Topic (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    NewTopic As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void Topic(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    String^ NewTopic,
    [OutAttribute] EatData% Return
)
type Topic =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        NewTopic : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
NewTopic
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserInvite Delegate

Delegate gets called when your IUser recives an IChannel invite

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserInvite(
    IServer Server,
    IChannel Channel,
    IUser User,
    out EatData Return
)
Public Delegate Sub UserInvite (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserInvite(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    [OutAttribute] EatData% Return
)
type UserInvite =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserJoin Delegate

Delegate gets called when your IUser joines a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserJoin(
    IServer Server,
    IChannel Channel,
    out EatData Return
)
Public Delegate Sub UserJoin (
    Server As IServer,
    Channel As IChannel,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserJoin(
    IServer^ Server,
    IChannel^ Channel,
    [OutAttribute] EatData% Return
)
type UserJoin =
    delegate of
        Server : IServer *
        Channel : IChannel *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserKick Delegate

Delegate gets called when your IUser is kicked from IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserKick(
    IServer Server,
    IChannel Channel,
    IUser User,
    string KickReason,
    out EatData Return
)
Public Delegate Sub UserKick (
    Server As IServer,
    Channel As IChannel,
    User As IUser,
    KickReason As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserKick(
    IServer^ Server,
    IChannel^ Channel,
    IUser^ User,
    String^ KickReason,
    [OutAttribute] EatData% Return
)
type UserKick =
    delegate of
        Server : IServer *
        Channel : IChannel *
        User : IUser *
        KickReason : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
User
Type: AdiIRCAPIIUser
IUser
KickReason
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserMessage Delegate

Delegate gets called when you send a message to IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserMessage(
    IServer Server,
    Object Window,
    string Message,
    out EatData Return
)
Public Delegate Sub UserMessage (
    Server As IServer,
    Window As Object,
    Message As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserMessage(
    IServer^ Server,
    Object^ Window,
    String^ Message,
    [OutAttribute] EatData% Return
)
type UserMessage =
    delegate of
        Server : IServer *
        Window : Object *
        Message : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Window
Type: SystemObject
Object
Message
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserMode Delegate

Delegate gets called when your IUser revices a umode

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserMode(
    IServer Server,
    string Mode,
    out EatData Return
)
Public Delegate Sub UserMode (
    Server As IServer,
    Mode As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserMode(
    IServer^ Server,
    String^ Mode,
    [OutAttribute] EatData% Return
)
type UserMode =
    delegate of
        Server : IServer *
        Mode : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Mode
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserNick Delegate

Delegate gets called when your IUser change nick

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserNick(
    IServer Server,
    string NewNick,
    out EatData Return
)
Public Delegate Sub UserNick (
    Server As IServer,
    NewNick As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserNick(
    IServer^ Server,
    String^ NewNick,
    [OutAttribute] EatData% Return
)
type UserNick =
    delegate of
        Server : IServer *
        NewNick : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
NewNick
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserNotice Delegate

Delegate gets called when your IUser recives a notice

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserNotice(
    IServer Server,
    IUser User,
    string Notice,
    out EatData Return
)
Public Delegate Sub UserNotice (
    Server As IServer,
    User As IUser,
    Notice As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserNotice(
    IServer^ Server,
    IUser^ User,
    String^ Notice,
    [OutAttribute] EatData% Return
)
type UserNotice =
    delegate of
        Server : IServer *
        User : IUser *
        Notice : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
User
Type: AdiIRCAPIIUser
IUser
Notice
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


UserPart Delegate

Delegate gets called when your IUser parts a IChannel

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserPart(
    IServer Server,
    IChannel Channel,
    string PartMessage,
    out EatData Return
)
Public Delegate Sub UserPart (
    Server As IServer,
    Channel As IChannel,
    PartMessage As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserPart(
    IServer^ Server,
    IChannel^ Channel,
    String^ PartMessage,
    [OutAttribute] EatData% Return
)
type UserPart =
    delegate of
        Server : IServer *
        Channel : IChannel *
        PartMessage : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
Channel
Type: AdiIRCAPIIChannel
IChannel
PartMessage
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
IServer
See Also

Reference

AdiIRCAPI Namespace


UserQuit Delegate

Delegate gets called when your IUser quits the IServer

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UserQuit(
    IServer Server,
    string QuitMessage,
    out EatData Return
)
Public Delegate Sub UserQuit (
    Server As IServer,
    QuitMessage As String,
    <OutAttribute> ByRef Return As EatData
)
public delegate void UserQuit(
    IServer^ Server,
    String^ QuitMessage,
    [OutAttribute] EatData% Return
)
type UserQuit =
    delegate of
        Server : IServer *
        QuitMessage : string *
        Return : EatData byref -> unit

Parameters

Server
Type: AdiIRCAPIIServer
IServer
QuitMessage
Type: SystemString
String
Return
Type: AdiIRCAPIEatData
EatData
See Also

Reference

AdiIRCAPI Namespace


WindowType Enumeration

The window types for a IWindow

Namespace: AdiIRCAPI
Assembly: AdiIRCAPI (in AdiIRCAPI.dll) Version: 1.8.0.0 (1.8.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WindowType
Public Enumeration WindowType
public enum class WindowType
type WindowType
Members
Member name | Value | Description
Server | 0 | Indicates the IWindow is a IServer window
Channel | 1 | Indicates the IWindow is a IChannel window
Private | 2 | Indicates the IWindow is a Iuser window
Chat | 3 | Indicates the IWindow is a Chat window
Tool | 4 | Indicates the IWindow is a Tool window (Rawlog)
Custom | 5 | Indicates the IWindow is a ICustomWindow
Panel | 6 | Indicates the IWindow is a dock panel window
Notify | 7 | Indicates the IWindow is a Trebar Notify window (ignore this)
See Also

Reference

AdiIRCAPI Namespace